cancel
Showing results for 
Search instead for 
Did you mean: 

Just got oculus, can't use steamvr suddenly?

RNG_Albino_BEef
Level 2

I just bought a Oculus Quest 2 yesterday, and was able to get airlink working with steamvr and played beat saber and superhot. Today I try to load it up and Airlink refused to work. I would open up the Airlink screen and try to connect to my PC, but the connect button was greyed out for some reason. I then tried to connect via a USB 3 to USB-C cable (it is the one that Oculus themselves sell). I set up the wired conection in the oculus app, and all seemed well, but when I enabled the link I was greeted by a black screen. I could see my play area boundries if i moved too close but otherwise was not able to get out of the screen unless i ended the wired link by pulling out the cord from the headset. At this point ive spent more time trying to get this thing to work than actually playing games on it, very dissappointing. Additionally Steamvr shows my headset as connected, and knows when its not being worn, but a las still the black screen. Is this a question for steam forums?

5 REPLIES 5

OculusSupport
Community Manager
Community Manager

Hey there, bud! We want you to enjoy your new device to the fullest, so let's work together to get you in the PCVR world!

 

To begin troubleshooting, we want to make sure your computer is compatible. Please check your PC specs against the table in this support article. If you find that your computer meets the minimum requirements, we want to suggest that you check to make sure your drivers are up to date. You can find the steps to do this in this support article.

 

If you need further assistance after trying these suggestions, just let us know. We're always happy to help! 😊
 

OculusSupport
Community Manager
Community Manager

Hello again! We wanted to check in to make sure you were able to get Air Link to work for you, or at least pinpoint what could be causing the issue. If there's anything we can do for you, let us know!

A1oNe_zTargeT
Level 2

I encountered this problem too and I suspect it happened after I updated the NVIDIA drivers to latest one. My dedicated graphic card is RTX3060 if it's relevant. The processor is Ryzen 9 5900X and does not come with any integrated graphic card.

 

UPDATE: Okay I tried using VorpX desktop viewer and it works so no more black screen but still no audio connected.

 

Finally fixed the audio by running the drivers exe as stated by the support.

 

 

OculusSupport
Community Manager
Community Manager

Hey all! Link and Air Link are great abilities of the Quest 2 and we wouldn't want you to go with being able to play PCVR with your Quest 2Please try to update your Oculus drivers in case a newer version is missing. Please follow the steps below to check for your driver updates:

  1. Close the Oculus app
  2. Press the Windows key + R on your keyboard to open the Run command
  3. Enter C:\Program Files\Oculus\Support\oculus-drivers
  4. Open oculus-driver
  5. Open the Oculus app and then try to connect your headset again

The next step we'd recommend would be to repair your PC software! Steps for doing so are listed below: 

  1. Go to www.oculus.com/setup and click Download Oculus Rift software.
  2. Select Repair.
    • If Windows asks you if you’re sure you want to open this file, click Yes.
    • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    • Please remember to re-enable your antivirus software once you've completed the repair.
  3. Allow the repair process to run, download and install.
  4. Launch the Oculus app.

Hope these steps prove useful in getting your Air Link and Link Cable to function properly! If not, please consider submitting a support ticket with your Log files so we can take a deeper look into what could be causing this issue! We wish we were able to receive your log files here on our Community Forums, however the file is too large to be sent here. Here are the steps for locating your Oculus Log files: 

  1. Open the Run window (Windows key + R).
  2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed the Oculus PC app to another drive you will need to update the command with the correct file path.
  3. Select the checkbox next to ‘Full logs’.
  4. Select "1 day" from the "Collect last" drop down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
  7. Attach the newly created zip file to your next support response.

Please submit your support ticket with Log files attached at the link here: https://metaque.st/Support! Scroll to the bottom of the page to "get support" to get in contact with one of our chat and email support agents! 

It was a GPU driver issue, sorry for any time wasted 🙂