cancel
Showing results for 
Search instead for 
Did you mean: 

Link cable is broken...

Adam.Legbel
Level 2
I was connecting my Quest 2 to my PC with link cable for like 4 month, but yesterday, when I clicked on the button to open Oculus link/rift S interface, it just load with the 3 white dot in the middle of the screen and nothing happen, any help?
 


I tried:
- Rebooting computer
- Rebooting Quest 2
- Restoring Quest 2 to factory settings (complete reset by holding the power and volume-down buttons)
- Reinstalling the Oculus App on my PC.
- Updating my graphics card drivers to the latest ones through GeForce Experience.
- Deleting the Quest 2 device entry on the Oculus desktop app, and adding it again.
- Rebooting the Oculus software through the "beta" tab in the settings of the desktop app.
- Verifying the cable connection through the Oculus desktop app in the devices tab. Results showed no issues.
- Trying Oculus Air Link instead of Oculus Link. This resulted in exactly the same results as with Oculus Link.
- Repairing Oculus App by launching OculusSetup.exe.

 

Nothing worked, what can I do, plz help...

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey there, Adam.Legbel! Getting stuck with a blank screen after so long is definitely odd. Given that you've already done so much work with your headset, PC and app, it may be worth looking at your cable.

 

  • Do you notice any damage, bends, breaks or kinks in your link cable?
  • Is there any damage or corrosion on either end of your link cable?
  • Is your link cable snugly plugged into your PC and headset?

If you don't notice anything out of the ordinary with your link cable or it's connections, please let us know. You can reach us with a chat or email by following this link.