cancel
Showing results for 
Search instead for 
Did you mean: 

Link fails to launch Oculus Apps (Home and Desktop) and some games

Jukes_McGee
Level 2

My fiancé and I recently both got Oculus Quest 2s. After connecting mine to my PC (i7-7700k and GTX 1080) and seeing Oculus Home and all the other apps we can access through PC, we went out and bought her an upgraded laptop (this one specifically).  It has an i7-11375H and an RTX 3060. We were expecting no issues setting up link and getting everything working because I was able to get link working (not well) on her old laptop with a GTX 960. Our specific problem is that we cannot launch Home, Virtual Desktop, or a purchased game (Raccoon Lagoon). Home will try to load and then crash back to the Oculus main menu. Virtual Desktop will connect to my desktop, but nothing displays. I can click around and my cursor will change based off what I'm hovering over, but I just see a black screen through my headset. Raccoon Lagoon will launch and show a loading icon for 1 second and then crash back to the Oculus main menu.

 

I spent almost the entire weekend chatting with Oculus support about this problem and we came to no solutions.

 

We've tried so many things to try to get it to work:

  •  forced laptop to use 5ghz WiFi

  • use hardwired internet connection
  • use Link Cable
  • disabled integrated graphics

  • disabled virus protection

  • disabled firewall

  • Update to the latest build of Windows 10

  • Update nvidia drivers

  • Do all windows updates (including the optional ones)
  • Uninstall and re-install Oculus
  • disconnect and reconnect Oculus to the PC
  • Factory reset my Laptop and tried again
  • Updated Oculus to the Test Version
  • Turn off Windows Game Mode
  • Turn off HDR in windows display settings
  • Ran the SFC scan and repair tool on windows
  • Tried different USC-c ports

Some notable things:

  • I am able to run steamVR just fine
  • I am able to run the Oculus tutorial/example apps and a free solitaire game I installed to test something other than Raccoon Lagoon

1 REPLY 1

Jukes_McGee
Level 2

I tried out Virtual Desktop and found that it seems to be an issue with the apps because they also crash when starting from VD. So, it must have nothing to do with Link.