cancel
Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Zandil
Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket

 

So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?

 

Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

178 REPLIES 178

I've tried using various adapters and max power output i get is 896ma.  I'm going to look for an "ACTIVE" cable to see if the added circuitry triggers the correct power draw.  The USB standard on power delivery is a hot mess and a bunch seems to be dependent on the device's firmware correctly asking for increased flow.  With 896ma I can get 4-6 hours of play time as I lose 10-15% per hour.  If the device would ask for 1250ma I think it would solve like 99% of the use scenarios

orcrist86
Level 3

Just found a cable on amazon that connect to the wall charger and the PC then combines the inputs so it can get the correct power to the headset.  I'm seriously debating picking it up.

Tell us about this...  Link?  Sounds like the best of both worlds.

here is the info.  It has both a usb c power side for the wall plug and a usb a data side for usb 3.0.  it also has a signal booster

 

OrxnQ 2 in 1 Oculus Quest2 Link Cable with USB C Charging Cable

LINK TO AMAZON

61LLwh5ix5S._SL1500_.jpg

71Ca3k-5g-S._SL1500_.jpg

orcrist86
Level 3

I bought the split cable and tried it out this morning.  I played for just shy of an hour and lost 8% at 72hz refresh rate, screen at max brightness.  This is much better than the 12-15% loss at 90hz I had been getting.  still not fully charging but I'll take the ability to play for 10 hours or so vs 4 or 5.  of course YMMV. caveat emptor and all that

Peterview
Level 3

Same problem here - official cable with ROG Strix X570F.   Used to charge fine before updates. 

teggroll
Level 3

It's possible I'm a bit late to the game here, but I may have found a solution. It's not particularly cheap, but it works. At least it does for me. I just finished playing about 2-3 hours of Half-Life Alyx and my Quest 2 headset was still at 100%. (Note: Important to read my update in the next post below)
 
Here is what I'm using (see links at bottom for specific products):

  • MacBook Pro running Windows 10 using BootCamp (see my notes below about using a PC laptop)
  • Thunderbolt 3 Dock/Hub
  • USB 3.0 Type C to Type C extension cable
  • USB-C to USB-C Thunderbolt 3 cables (2)

The way I'm connected is as follows:

  1. MacBook is powered by its AC adapter (Usually you wouldn't need the AC adapter, the hub would power the laptop. But the laptop won't charge in the configuration you need for this to work.)
  2. The hub is plugged into power using its included AC adapter.
  3. The laptop is connected to the hub with one of the Thunderbolt 3 cables. The hub has two Type-C ports on the back - one with lightning bolt and laptop icons (or the word "Computer" instead of the laptop icon), the other with just a lightning bolt icon. Plug this Thunderbolt 3 cable from the laptop into the one that DOES NOT have the laptop icon. Why? Because the port with laptop icon is the only one, at least that I have found, that will charge the Quest 2 while in use. I've tried it using the other Type-C port for the Quest 2 and it didn't charge, or at least it didn't keep it at 100%. It may have charged slowly, but was unable to keep up with the power usage of the headset. This is also the reason the laptop needs to have its AC adapter connected because with the laptop plugged in to the port it would normally not be plugged into, the laptop doesn't charge.
  4. The USB 3.0 Type C to Type C extension cable is connected to the hub's other Type-C port, the one that DOES have the laptop icon.
  5. The other Thunderbolt 3 cable is connected to the extension cable and to the headset. I used a couple of Velcro cable straps to secure the cable to the side frame of the headset to relieve any tension on the headset Type-C port and to prevent the cable from pulling loose during use.

And that's it. That is how I play now and, as I said, the headset remains at 100%.

 

NOTES:

  • Will this work with a PC laptop or a laptop without Thunderbolt 3? Not sure. I don't know if the success of this setup depends upon Thunderbolt 3, or if the products I'm using (MacBook and hub) just happen to be Thunderbolt 3 and sufficient power is provided regardless simply because of the USB 3 spec.
  • Make sure your connection is "hub > extension cable > Thunderbolt 3 cable > headset". I tried switching the order of the extension cable and the Thunderbolt 3 cable and it didn't charge the headset. Also, having the shorter cable Velcro-ed to the headset makes it easier to disconnect the headset if you should want to charge it using it's AC adapter or pack it in a case to take it somewhere.
  • I believe my dock came with a Thunderbolt 3 cable. So whichever hub you buy, check to see if a cable is included. You may only need to purchase one additional Thunderbolt 3 cable.
  • My hub is the Sonnet Echo 11 Thunderbolt 3 Dock, so that is the only one I can say for sure works. I have included links to a few other Thunderbolt 3 docks that may also work because they also have the similarly marked Type-C USB ports on the back. Check the specs to see how they compare.
  • I don't know what variations on the products linked below will work. It seemed as though I had to hit on a specific combination for it to work. Your results with alternative products may vary.

Good luck!
 
LINKS (not affiliate links 😄 )
Thunderbolt 3 Docks/Hubs

USB 3.0 Type C to Type C Extension Cable

USB-C to USB-C Thunderbolt 3 cables

teggroll
Level 3

Update #1

It now seems impossible for me to predict a solution to this Oculus link charging issue. Today, with everything still configured as I outlined above, after 2-1/2 hours of playing Half Life - Alyx, the Quest 2 headset was at 50%, not 100%. Not sure why that is. I will monitor the post-play charge levels over the next few days and see if there is any consistency. At the moment, I cannot confirm that this configuration is indeed a solution. If anyone considers configuring their set up similarly, be sure the products are returnable if it doesn't solve the issue for you. Apologies for the bump in the road. Not something I would have anticipated.

EnKixHGM
Level 3

[from a post I put in the wrong place]

I have suffered this same issue for months thinking it was a possible Oculus update situation and waited for a fix.

I was using an add in pcie card (BEYIMEI PCI-Express 4X to USB 3.1 Gen 2) with 2 ports known to provide enough power.  It worked fine for months, but then out of the blue it simply stopped charging.  I tried replacements and still nothing.  I still do not know what caused the cards to stop providing a charge, but using my motherboard's built in port is now working perfectly.  I have a gigabyte aorus master Z490 motherboard.

 

I would prefer to use an add in card and not stress the motherboard components for this kind of amperage, but apparently there are ways to make it work right depending on your hardware.  I do still hope for an update that will make any of the add in cards that can provide the proper amperage draw work again, or at least the discovery of an add in card with better quality components to satisfy our energy hungry headsets.

Peterview
Level 3

Just to share, Oculus support have clearly told me that the headset was never designed to charge while connected to a PC via the Link Cable - therefore, none of us should expect it to charge.  I can't help but think they are making this stuff up - too bad it did not say this clearly on the box - I would never have purchased the device.   Odd that it worked fine for months for me and then stopped after updates.