Showing results for 
Search instead for 
Did you mean: 

Logitech keyboard support

Level 2

Hi, I wonder if someone can confirm something before I pull the trigger on an order, Logitech MX Keys keyboards are now supported after last update, are both supported, MX Keys and MX Keys Plus? I'd really prefer the Plus with the numeric keypad, can't really find much info on quick web searches.




Level 3

I can confirm the keyboard is working fine with v40. As long as you don't need any other language than english (the åäö keys on my keyboard does NOT produce what they should, the language support is just crap). Also when setting it up there's a choice if you've got the model including numerical keys or not, and also a choice if you've got the Apple or general version (though I have never heard of an Apple version of it anywhere else).

Level 3

I just bought the MX Keys Plus, the input works but I can't get Oculus to see the keyboard in the headset.  Waiting on tech support from Oculus.

hey guys, ordered, arrived and working, @guppy_blast i move it sometimes and press keys just to "wake it" sometimes, after pairing it worked fine for me.


Hey there guppy_blast! We see you're having trouble getting the Oculus to see your keyboard in your headset. We would like to know if you're currently on the latest update, Meta Quest Build 40.0? 

Yes, I am running 40.0 Build.

Hey guppy_blast, thanks for the update on your current headset version!


Just to confirm, have you tried any troubleshooting steps? If so, could you please list those out so to not repeat any?


This might seem a bit basic, but have you tried to reset the keyboard settings and repair the keyboard, as well as a headset reboot through the boot menu?


To reboot your headset:

  • Turn off your headset.
  • Press and hold the power and volume down buttons together until the boot menu loads.
  • Use the volume buttons to highlight the 'Exit and boot' option and press the power button.


If that doesn't seem to fix the keyboard view, don't hesitate to reach back out to us here for further assistance!

Level 3

I had already tried deleting the keyboard as a Bluetooth device and reconnecting/pairing the device.  This didn't work.   I just tried "Boot Device" from the Boot menu as suggested above but that did not work either, I'm still getting the same indication.

Level 3

Also, restored defaults on the keyboard as well.  I am running Logitech Firmware Version 012.001.00013

Hey! Hope you are having a good day. We would like our team of specialist to look into this with us. 


Please submit a ticket here, we ask that you please share every detail with our specialist. Also check out this link here, this article will lay out the tracked keyboard we support. 


We hope to hear back from you soon! 


Let's get to work!