cancel
Showing results for 
Search instead for 
Did you mean: 

Messed up controller for quest 2

duckboy17
Level 2

i was playing vr, then my quest 2 controller (left) started connecting and then disconnecting, I tried to replace the battery twice but then it fully disconnected,

I looked in the app, it said it had no battery. But it was still flashing. I tried unpairing and repairing it, but it wouldn’t turn on at all, after a day I was able to pair it, (right now) and it does 3 really fast blinks, then 3 normal blinks, does this for about 30 seconds then stops. Every time I try to play it doesn’t appear. I’m too scared to try any hacks like putting foil in the battery spot. WHAT DO I DO? PLEASE HELP!!!!

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Aww man, duckboy17! Glitchy controllers are never fun, we advise you to please remove your batteries for a minimum of 30 minutes. Then, attempt to repair them again after you've rebooted your headset. https://metaque.st/QuestRestart 

 

If the issue is persistent, feel free to submit a support ticket as one of our lovely agents will be glad to get you closer to a possible solution. https://metaque.st/Support