cancel
Showing results for 
Search instead for 
Did you mean: 

My Oculus Quest 2 does not show any of my games/apps in my library after I did the recent update

LtWagz
Level 3

I recently bought a game called "Swarm" and noticed that when I bought it on my phone it never showed up on my headset. Both my phone and headset are connected and are on the same wifi, so I was confused. As I was trying to fix it, I saw that I needed an update for the Oculus software on my headset so I tried that out. Once the update was complete, I launched my headset to find only settings and browser in my library. I checked if my games were in a different category such as "not installed", but still nothing showed up. I need help fixing this issue, so if anyone knows any way for me to get my stuff back on my headset please let me know. (Just to clarify, I am logged in with the same oculus account as before and also I did not factory reset my device yet).

26 REPLIES 26

I did a factory reset as well losing all media with no solution

skizmdj
Level 2

Bought mine. Booted up today. Bought a game (Arizona) and tried to get YouTube VR and Netflix... spinning wheel.
Not showing in 'Not Installed'. Not allocated space either.

 

Lol likely to go away after I spend hours on it.

skizmdj
Level 2

It looks like they've pushed out a fix. I've been turning it on and off each time I've been testing to see if it is working (in case you want to try that one more time). The notification bell should be blue and there should be 2 updates in total.

That fixed my issues.  Thanks for the heads up that a fix had been pushed out.  All my games are back.  Yayyyy!

GoGoshiK
Level 2

I tried this and worked....

 

Restart quest

Go manualy and check for updates

It told me that no update found

Restart again

The quest updated by itself and games were there, ready to play. 

 

So..... 

Just push on to next update.

My saves are there, no problem on that. 

melliimelz
Level 2

so what your telling me is the app/games are just in some sort of limbo until oculus fixes the issue or was it just a total waste of money?