cancel
Showing results for 
Search instead for 
Did you mean: 

Noise when moving joysticks/thumbsticks in SteamVR games?

pjtheplayer
Level 2
This happens to me on ADR1FT and Elite Dangerous and I assume other games will do it as well.  Whenever I move my thumbsticks a little in any direction i get this weird, sort-of beeping noise that's really annoying.  Not sure what's causing it.  Anyone else experience this?
15 REPLIES 15

pjtheplayer
Level 2
After doing a little investigation I've realized what's happening.  The beeps are the same sound it makes if you are in the Oculus Home menu and you press the joystick in a direction you cannot go any further in (like if you're all the way to the right and you press right again it makes this sound).  I've also noticed pressing "A" makes the selection sound.  This leads me to believe that Oculus Home is somehow still running in the background while I'm in SteamVR mode.  However I have not figured out a way to fix this.

RobHermans
Level 9
Sounds like the sort of thing you get when the volumes on your sound setup are out of whack, maybe? Check that your don't have the sound on both the game and Control Panel set to 100%.
Also, check that your have the latest drivers for your sound device.

RobHermans
Level 9
Oh, I posted before I had read yours...is there a Launch option for those games? If Oculus Home is still running inadvertently, perhaps you have to "Launch in SteamVR" or something like that?
Sorry, I don't have my Rift yet. :blush:

pjtheplayer
Level 2
Thanks for the quick response Rob.  I don't think that's the issue though - if I turn the control panel sound all the way down (Detected as "Headset - Rift") then I lose both the game audio and the beeps.  It's a bizarre issue for sure.  

RobHermans
Level 9
Don't mention it...got nowt else to do while waiting for my Rift!
Nah, don't turn it all the way down.

I remember reading somewhere that you need to launch SteamVR games with that special option.

pjtheplayer
Level 2
So I managed to fix it but I'm not sure how.  I went into the Oculus settings and turned the volume all the way down.  Tested the game again and there was no sound at all so I figured that didn't work.  Turned the sound back up and the issue is gone.  Doesn't really make any sense why that worked but it did.

kojack
Volunteer Moderator
Volunteer Moderator
Even if you are using a Steam VR game launched from Steam, if you are using a Rift then the Oculus Home app is running in the background. SteamVR uses the Oculus SDK.
(It shouldn't keep input focus though)

Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Zandil
Level 8
I used to get this when I shut down my Xbone controller with the wireless adapter then my mouse would do the beeping thing, I ended up doing a firmware update on the controller and that fixed it for me. 

If your running WIN 10 there is an app in the window store called xbox accessories ( i think that'd what it is called ) load it up and it will tell you if you need to update the controller firmware and it does it for you. 

pjtheplayer
Level 2
Yeah this is still a problem.  Just launched Elite Dangerous and that fix I mentioned isn't working.  And Zandil I actually know what you're talking about and that's an entirely separate issue that I also experienced a few months ago and had to fix.