Showing results for 
Search instead for 
Did you mean: 

Oculus Client just shows a spinner and never loads.

Level 2
I'm trying to install a new Rift. I've run the Setup.exe file, successfully installed everything, even ran the Patch.exe from March 2018.
When it gets to the part of the installation process where I'm supposed to "login," it launches Oculus Client. Oculus Client just doesn't do anything. It sits there with this spinner forever:
I've tried uninstalling, reinstalling, rebooting, updating Windows, you name it. Nothing is getting this spinner to go away.
My Rift is apparently _unusable_ until I login through this app. Steam won't acknowledge that I have a Rift connected, and I can only assume it's because I have not logged in through this app, despite being able to login through Edge browser (login on Chrome doesn't work either, go figure).

Anyone know how I can solve this? I don't care for this EXE in particular. If I can just get Rift to work _at all_, I'll be much happier.

Level 2
I have the same exact issue. Turned off firewall, reinstalled, rebooted, etc. Nothing works. Any help would be great

Level 2
same issue

Level 2
Hey guys, I was able to fix it after Zendesk chat support helped.

Uninstall Oculus software from the Control Panel.
Turn off firewall and antivirus.
Run the installer from command line, like so:
OculusSetup.exe /drive=D

This changes the default installation directory from
C:\Program Files
D:\Program Files
. For whatever reason, this was the crucial part for me, I think. It may be because my default installation directory for Windows is the D drive.

Full disclosure, I ran the installer through a shortcut, adding "/drive=D" to the shortcut, so that I could also run it as administrator. You may want to do the same.

For anyone else seeking help on the forums, I highly recommend the Zendesk support chat. You have to disable Adblock to see their chat popup, but I got a working program from them after about two hours, versus the three days I'd waited on an email or community answer before giving up.

Good luck,