cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Desktop closes 2-3 seconds after I open it when SteamVR is active

keltrivera
Level 2
After certain oculus software update around September, 13 or slightly before Oculus Desktop app started to close almost everytime after 2-3 seconds or slightly more while SteamVR is active. Without SteamVR running it works as expected. I've tried clean install of different Nvidia drivers, new and old ones, using SteamVR normal, beta and old beta, PTC and non PTC Oculus software, reinstalling SteamVR while cleaning all the folders and registry enters left, clean reinstallation of Oculus software after uninstalling it and removing all the files, folders and registry entries which mentioned Oculus. I'm running Win 10 x64 with latest update available, My MB is asus rog z370-f, CPU is I7-8700k, GPU is evga 1080 ti ftw3 hybrid. Pretty much no idea what causes this. Any help would be greatly appreciated
5 REPLIES 5

cleanupdisc
Level 5
In the settings on oculus do you have “allow 3rd party apps or software to use this device” checkmarked? (Or something to that effect). 

Just make sure you have that setting on to allow steam vr to work with your oculus rift.

Benny1994okyo
Level 2
cleanupdisc I have the same problem and unfortunately turning the "allow 3rd pary apps or software to use this device" box on or off does nothing to fix it. keltrivera please let me know if you found a fix to this problem. 

TomCgcmfc
Level 16
Well for sure you need the allow 3rd party apps enabled.

I have not had any problems, nor have many others.  So I suggest it is a win10 system thing, a PC port problem, or a faulty hdmi cable.  Who knows?  Probably best to try to work this all out though with Oculus Support imho.

Maybe make sure your USB's in win10 device manager all have the usb power saving/suspend option off (you can also do this in your win10 power plan settings.  Not sure, but you may need to do a win10 reinstall (hope not!).

Good luck sorting this out mate.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, Corsair 750w, Quest 1 w/Link and wireless w/VD, Vive Pro.

F1R3CL0UD
Level 2
I am have this issue also. This feature worked fine over the beta before the 2.0 update. But now I cant find a fix or a workaround. Has anyone found a fix yet? Please help.

Darkmaster2110
Level 2
Been having the same issue for a while, still haven't found a proper fix.