Showing results for 
Search instead for 
Did you mean: 

Oculus Link/Air Link too jerky/stuttery to use

Level 3

My Oculus Quest 2 PC Link has got so stuttery it's unplayable. It didn't start out this way, it was fine, but over the last few days it has rapidly got worse. I was playing on Air Link (WiFi 6 confirmed) and tried restarting the headset, the router (WiFi 6/802.11ax 1200mbps), the PC (2.5gbps ethernet), changing the AP settings, took everything else off the network and that didn't help. I then connected the headset to the PC using the direct USB link and that didn't help either. I've tried different cables and ports, confirmed the Oculus software says it's running at USB 3. I'm running the default settings (72hz, automatic resolution scaling, automatic bitrate for Air Link) but increasing/decreasing any of those three settings basically make no difference (increasing the framerate to 90-120 "kinda" smoothes it out, the jerkiness is still there but since it's happening at a higher framerate is slightly less noticable, but still completely disruptive). I've got late-2020 Alienware m17 R3 laptop with a Core i9 10980HK 5GHz and RTX 2080 Super, 32GB ram, Samsung 970 EVO Plus NVMe SSD.



Could you please clarify a little? Not sure what you mean with ODT for instance. Sorry, I'm a complete computer novice

ODT, or Oculus Debug Tool, is a tool for users that have Developer mode enabled on their headset, Skyseras. The method CmdrShepardsPie is referring to is launching the ODT, navigating to Service > Toggle console window visibility from the menu. This changes the window priority to improve the performance on Windows 11, so the priority would be as follows:

  1. SteamVR (If you indulge in those third-party applications that we do not support)
  2. Oculus Service Window (enabled through the ODT)
  3. Game application window

Users have also found success using the application sold on our store, Virtual Desktop, since they have recently updated their codec to fix issues related to Windows 11. You can find out more about Virtual Desktop through the developer Discord server, or through their Webpage.


The only Windows 11 versions we've seen work are the ones directly upgraded from Windows 10. Something about Windows 11's folder infrastructure seems to have changed, so installing the Oculus app fresh onto 11 just won't work properly. The only real option we can say at the moment, is creating a partition to download Windows 10 onto, specifically for VR purposes, though, we cannot officially advise doing that. If you still qualify for reverting back to Windows 10, we suggest doing that for the time being until we roll out an update for Windows 11 support.


Hopefully that clarifies a bit better of what's going on. There's some complicated tech lingo in there still, but we hope it still qualifies as a satisfactory answer!

@OculusSupport wrote:
  1. SteamVR (If you indulge in those third-party applications that we do not support)

You make it sound like using the biggest PC gaming library on the market is some sort of vice, and then push people to go and buy something from the Oculus store. 


Customers aren't supposed to be treated like infantile cash cows. Airlink clearly has a bug that needs fixing. Any ETA on if this is even in the hands of a dev team yet?

That did work for me but after 1 day it stopped working. basically it started stuttering again and the console window visibility didnt help anymore.

Could you expand "ODT" for me? I don't know that acronym.

Oh wow!

This actually worked for headset was twerking, but the graphics were actually looking good behind the jumpiness. 

ODT is the Oculus Debug Tool and that can be found by going to:

C:\Program Files\Oculus\Support\oculus-diagnostics and clicking 'OculusDebugTool.exe"

Once you've done that, go to 'Service' in the window's nav bar, and click on 'Toggle console window visibility' 

A command prompt window should pop-up and when you go back into Oculus Link, the stuttering stopped.


I'm currently using an iMac 2020 on bootcamp with a Radeon 5700xt graphics card, 

@ynleborg do I have to do this everytime? 



Level 3

@chrischrisonvr Once enabled, it should be active after a reboot. But I must say it is annoying, to have this window with logs enabled all the time. So I toggle this only when I'm going to use the headset.