cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link/Air Link too jerky/stuttery to use

CmdrShepardsPie
Level 3

My Oculus Quest 2 PC Link has got so stuttery it's unplayable. It didn't start out this way, it was fine, but over the last few days it has rapidly got worse. I was playing on Air Link (WiFi 6 confirmed) and tried restarting the headset, the router (WiFi 6/802.11ax 1200mbps), the PC (2.5gbps ethernet), changing the AP settings, took everything else off the network and that didn't help. I then connected the headset to the PC using the direct USB link and that didn't help either. I've tried different cables and ports, confirmed the Oculus software says it's running at USB 3. I'm running the default settings (72hz, automatic resolution scaling, automatic bitrate for Air Link) but increasing/decreasing any of those three settings basically make no difference (increasing the framerate to 90-120 "kinda" smoothes it out, the jerkiness is still there but since it's happening at a higher framerate is slightly less noticable, but still completely disruptive). I've got late-2020 Alienware m17 R3 laptop with a Core i9 10980HK 5GHz and RTX 2080 Super, 32GB ram, Samsung 970 EVO Plus NVMe SSD.


https://www.facebook.com/CmdrShepardsPi3/posts/1560115237689754
https://www.facebook.com/photo.php?fbid=1560123174355627&set=p.1560123174355627&type=3

 

1 ACCEPTED SOLUTION

Accepted Solutions

ynleborg
Level 3

I have finally found a solution: "ODT->Service->Toggle console window visibility". After the restart "strafe stutter" disappeared (kudos to Advanced VR fare on YT)

View solution in original post

18 REPLIES 18

OculusSupport
Community Manager
Community Manager

Hey there Pie! Sounds like a doozy of an issue! Luckily we're here to assist with what troubleshooting steps we can provide and hopefully get your link services running better. We see you've tried a good amount of troubleshooting steps to no avail. We have a couple more for you to try below:

You might want to dive into your router`s settings (refer to the manual) and make the following changes (if applicable to your specific router):

  • Change network mode to 802.11ac or 802.11ax only
  • Find and use the least congested Wi-Fi network channel
  • Change channel width to 40 or 80 MHz
  • Disable Smart Connect
  • Disable Quality of Service (QoS)

Raising the processing priority by following these steps:

  • Open “Windows Task Manager” (CTRL+ALT+DELETE)
  • Navigate to the “Details” tab
  • Find OVRServer_x64.exe process
  • Right Click and “Set priority” to High or Realtime

Ensure all windows and GPU drivers are installed correctly and up to date. If you follow these steps to no avail please reach out and submit a support ticket here or PM us by clicking here or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message. We hope this helped! 😁👍

ynleborg
Level 3

I have finally found a solution: "ODT->Service->Toggle console window visibility". After the restart "strafe stutter" disappeared (kudos to Advanced VR fare on YT)

I don't have access to those settings on my router (they're "managed" by my ISP) but it is set to 802.11ax and "40/80MHz" channel, I don't see anything about Smart Connect or QoS, but the same problem happens whether I'm wired directly or wireless so I do not think the wireless is the problem. I think the problem is on the computer, possibly around the capture and/or encoding of the video stream (if it works how I think it does).


I noticed something today that one time I started it up everything was running perfectly smooth for about one minute then it started continuously stuttering/jerking after that. From that it seems to me there's some condition the computer gets in that causes it to start stuttering. In my head that means it falls behind and can never catch up, but I don't know really.


An anecdote: I saw something similar to this when I had a faulty Freesync monitor. Sometimes a game would drop in FPS and get "stuck" there, and rather than coming back up to a higher frame rate it would just stutter continuously. It looked very similar to what I'm seeing here, both in apparent motion and in the frametime/fps graph from my video/picture on Facebook. The solution that time was to get a different monitor, but I think this is happening in the software on the computer.


Anyway, still having the problem with the Quest 2 Link here. Some friends told me to turn off async warp in the Oculus debug tools, but that didn't help either. 

ynleborg
Level 3

What version of Windows are you using?

Windows 11 Pro 21H2 1000.22000.376.0 but that hasn't changed since I got the Quest 2 (about a week ago).

Hey there! We understand your headset was working well before with Windows 11, but to ensure the best performance with Link, please use Windows 10. Windows 11 is not yet supported with our Oculus PC software.

 

If you decide to go back to Windows 10, please make sure you're using the latest version to experience the best performance. If you still experience these same stuttering issues after using Windows 10, please submit a support ticket. Our team will be happy to help. 😊 

I see multiple tickets spanning 7 months regarding this issue. What is your current status regarding addressing this.  Its obvious you've known a massive issue exists,  when can we expect an update?

CmdrShepardsPie
Level 3

I can confirm (in my case) that the constant stuttering was only happening in Windows 11. Going into the Oculus Debug Tools and toggling the console window visible made the stuttering stop, as long as the window was in the foreground and focused. I found this a little annoying, so I went back to Windows 10 and no longer have the problem. (This is the only piece of software that had any problems in Windows 11.)

I can confirm (in my case) that the constant stuttering was only happening in Windows 11. Going into the Oculus Debug Tools and toggling the console window visible made the stuttering stop, as long as the window was in the foreground and focused. I found this a little annoying, so I went back to Windows 10 and no longer have the problem. (This is the only piece of software that had any problems in Windows 11.)