cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link Cable Charging but not Linking to PC

0xbeefbabe
Level 2

I'm trying to connect my Oculus Quest 2 to my PC via the Oculus Link Cable. When it's plugged in the Oculus Quest 2 shows that it is charging, but it is not giving me an option to allow data transfer, nor does it appear in my file explorer. So far I've tried:

- Using air link instead (my wifi config does not allow it)
- Turning air link off
- Allowing the Developer USB window thing in the settings
- Restarting the PC and the Oculus
- Updating drivers/software on the PC and Oculus (and restarting again)

I'm really disappointed as I've spent £90 on a cable that is now useless to me for its intended purpose. Is there anything else I could be missing or do I need to bite the bullet and get a new cable?

5 REPLIES 5

TomCgcmfc
Level 15

What are your pc specs and how are you connecting it to your PC?  What windows version and are all your drivers up to date?  Pretty hard to make suggestions without knowing this.  Otherwise contact oculus support and see if they can help.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

i7-9700K, rtx 2060, 16 gb ram, plenty of space on an SSD. Connecting to a USB C on the 2060. Windows 10. All drivers are up to date. Used to work fine before. Used the quest independently for a while, and now the cable's not working. Gonna try to contact support to see what they have to say, thought this was how to do it

 

Same issue, after update 37, submitted a ticket… Worthless support. 

@HandsomeSnake  I feel your pain mate.  Some updates in the past have also not worked out well for me.  Often this has been a combination of Oculus, win10, and Nvidia updates, lol! If you hang in there and do a bit of googling I'm sure you'll sort this all out.  Cheers.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

BluBlaze9905
Level 2

Having the same issue, except mine worked the day before it wouldn’t work. Extremely infuriating