cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link connection problem with cable and Air Link.

b.gidirisli
Level 2

Whenever I try to connect my Oculus Quest 2 to Oculus Link, the Oculus Link main menu has a white background for a few seconds but then a black screen comes up and this keeps repeating. My computer is Lenovo Legion Y530. My drivers are up-to-date and I'm using Windows 10.

4 REPLIES 4

OculusSupport
Community Manager
Community Manager

Hey there! Let's look into this together and get you up and running with Link. From the info we see about your laptop, it has a GeForce GTX 1050 Ti graphics chip. This graphics chip is not supported with Oculus Link. For a list of compatible graphics cards, please click HERE. Once your PC is fully compatible, please ensure that you're using our Oculus Link cable for the best performance and try again. We hope this helps, and we're always available to help further if you send in a support ticket HERE. Thanks!

Thank you for your reply. First of all, I was connected to Oculus Link before with my 1050 Ti graphics card before and I had no problems before. Second, I tried my headset with other computers with supported graphics cards such as 3050 Ti and 3080. I encountered with the same problem before, the main menu screen and Oculus logo comes and goes to black after one second and this cycle goes on. When I check the Oculus App, it says "General Device Problem". I tried lots of solutions that I saw in Reddit and Oculus Forum and its no use.

Hi, we understand you've tried to resolve this issue on your own. We appreciate you letting us know Oculus Link has worked for you before. This Oculus Link and Air Link issue could be a result of a recent outage our servers experienced earlier this week. The outage effected a lot of our services. While most issues have been fixed, our team is still working hard on a resolution PCVR related issues.

 

We understand this is not the solution you were looking for, and we want to do our best to help. In case this issue is not related to the outage, if you haven't already please submit a support ticket with all troubleshooting you've tried so far. We would hate to waste your time by suggesting steps you've already taken. We hope to have you back to enjoying PCVR soon. 🙏

Here is the video of the problem I am having. I tested it today on a laptop with 3050Ti and updated to the latest version.