Showing results for 
Search instead for 
Did you mean: 

Oculus Link not working

Level 3

When I try to open Oculus Link it will load for a few seconds then send me back to the Quest menus. It shows that Im connected just fine on the PC app before and after this happens, and it was working just fine a few days ago. I tried redownloading the app and factory resetting the headset neither of which worked. Its not a cable issue because it has the same problem when I try to use Air Link.


Oculus Community Manager
Oculus Community Manager

Hey there ItsFelix, we always want to make sure you can enjoy all of your favorite games. Lets get your Oculus experience back up to 100%! Below I've outlined some troubleshooting steps you could try to alleviate any potential link issues.

Are there any updates to Windows/GPU/USB?

Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but is applicable to Quest/Quest 2 as well.

For Windows, there's an article on how to check for updates here!

If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.

Game Mode may conflict with some VR applications.

In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes, and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.

  • Open the Windows Settings menu
  • Click on Gaming
  • Click Game Mode
  • Toggle Game Mode off

If you have any other questions or concerns, we'd be happy to help! Cheers!

My drivers are all up-to-date, and I do not have Windows game mode turned on.

Oculus Community Manager
Oculus Community Manager

Hey there, thank you for getting back to us with that update.


We would first like to ask what hardware are you currently using to link your headset? As well as in the meantime, we want to provide you with a couple of more troubleshooting steps. 


To get started, please do manual uninstall of the software by following the steps below:

  1. Disconnect your computer from the internet.
  2. Backup any necessary content.
  3. Reboot into Safe Mode.
  4. Uninstall Oculus Home using the Control Panel.
  5. Delete all Oculus folders from the following folder:
    • C:\Program Files
  6. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  7. Restart your computer in normal mode.
  8. Reconnect your computer to the internet.
  9. Install Oculus Home again using the setup tool from our website here.

Please be sure to respond back here, so we can resolve this matter together.

Level 3

I have already tried uninstalling the Oculus app completely several times as well as factory rebooting the headset and neither have helped. I'm certain it is not a connection issue with the cable either as I've tried multiple different cables and the same problem occurs.

My computer's hardware is as follows:
Windows 10 x64
AMD Ryzen 9 5900HX Processor
Nvidia GeForce RTX 3060 

Oculus Community Manager
Oculus Community Manager

Hey ItsFelix, thank you for providing us with your PC specifications. Have you tried resetting your graphic preferences to the default settings? 


Please perform the following steps:

  1. Open the Oculus app on your Computer.
  2. Click Devices on the left side of the app.
  3. Click Quest and Touch.
  4. Click Graphics Preferences.
  5. Click Reset to default.
  6. Click Save and Restart

If you are still unable to use your Oculus Link, we recommend reaching out to us through DM or through our Support Page. Please include your Oculus Logs so we can determine if there's an underlining issue which may be preventing you from using Oculus Link. We look forward to hearing your results! Thanks.