Showing results for 
Search instead for 
Did you mean: 

Oculus Link not working

Level 2
I got my Oculus Quest a week ago and it was amazing. I played some games and I wanted to try Oculus Link. It tried it and it worked normally. I played some games from the Oculus app and Steam. Suddenly, Oculus Link stopped working and I don't know why. I was using the cable that came in the box. The wired thing was that the usb-c port was no longer charging my Quest. A week passed and I wanted to see if Oculus Link worked, and this time it worked. I was able to play games normally, but after some time it stopped working like the last time. I tried fixing it in the device manager, but it didn't work. I unpluged and repluged my Quest and that also didn't work.This can't be caused by the cable because it charges the headset when it is pluged into the wall. Just to keep in mind that I was playing on a laptop that isn't VR ready (Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz, 16gb RAM, NVIDIA GeForce GTX 1050 4gb). However, that shouldn't be the problem because even a PC that is not VR ready should at least charge the headset. I also restarted my laptop and my Quest multiple times but that didn't fix anything. Maybe the usb-c port is the problem, but I can't confirm that. Does anyone have this problem? I hope it's a software issue so I don't have to take my laptop to the warranty service.