cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus PC App Won't Install

TomDurnell
Level 2

When I go run the installer for the Oculus PC app, it will get to the end of installing then bring up an error saying something went wrong and to restart the PC. I've done this and reinstalled multiple times but to no avail. I've tried installing to a different disc, deleting all the leftover files... I've even tried going back to Windows 10 and installing again but still comes up with the same error. There is also 100GBs of storage left on my discs so that cant be the problem

 

My specs:

Ryzen 5900HX
RTX 3070

64GB RAM

2 x 1TB Samsung 970 SSDs

 

Please help!

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there TomDurnell, 

 

Thank you so much for reaching out. We fully understand that Oculus Home is a necessity for any PC gamer. 

 

There are a few steps we can try so you can fully immerse yourself in the ever expanding world of VR. 

  • Disable anti-virus or firewall
  • Double check your Wi-Fi connection  

Should those not correct the issue, for us to better assist we would need you to submit a support ticket and send us the log files of your Oculus Home app.

 

We really want to help you out. Let's find a solution together.