cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 | SteamVR stuttering

Anonym42
Level 3

Using Airlink or the USB-C cable, I connect my Oculus Quest 2 to my computer where I am using both Windows 10 and Windows 11 on (two different M.2) with the following specs

- i9-9900k OC'ed to 4.7 GHz

- 32 GB RAM

- RTX 2060 Super

 

As soon as I start SteamVR and watch left or right, it already stutters sometimes.

When starting a game like 'Arizona Sunshine', the stuttering becomes more often.

After a few minutes of playing, it is over. When watching left or right anything freezes and I just see something like "grey walls" with a lot of colored pixel lines everywhere and have to turn the whole thing off.

When I check taskmanager right afterwards, it shows me

RAM usage: ~50%

CPU usage: ~50% at <50 °C

GPU usage: ~40-70% at <70 °C

 

I have already reinstalled the GPU driver to the newest version and an older one.

I have already reinstalled the Oculus software.

It doesnt matter if I reconfigure the ingame graphic settings to really low / high.

The behaviour is just always the same.

 

Any suggestions what could cause these performance issues?

Thanks a lot in advance!

 

19 REPLIES 19

Bizla
Level 3

I posted yesterday with a temporary fix for this.  One thing I forgot to mention in the post was to set OVserver_64 to High priority in task manager. 

https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/Windows-11-stutter-link-cable/td-p/894805

Anonym42
Level 3

Unfortunately this did not help (I have tested it on Windows 11, I am experiencing the same issues in Windows 10 as well but did not test it there).

What I have done after reading your post:

- quit SteamVR

- start ODT

-> Service

-> Toggle console window visibility

- after the Oculus app was restarted, I went to taskmanager and set OVRServer_x64.exe priority to high

- put on quest 2 & connected through airlink

- went to Desktop View and started the game directly from Steam

-> SteamVR started and I went into the game

 

Just another expierience of horrible lags. Even after closing the game (back in SteamVR) I could not watch around, just weird grey graphics with colored pixel lines in it and really laggy (I dont know how to describe that).

Immediately put off the quest 2, checked taskmanager

- CPU ~50%

- GPU ~50% <60 °C

 

Console shows errors like this from time to time, I dont know if this is a "normal" behaviour:

20/11 12:18:42.339 {!ERROR!} [RemoteHeadset] getHostFrameTiming: Failed to retrieve frame timing.
20/11 12:18:42.339 {!ERROR!} [RemoteHeadset] 1. Could not retrieve round trip frame timing

20/11 12:18:42.347 {!ERROR!} [Kernel:Error] [Aggregated 59 times] OVR Error:
Code: -6101 -- ovrError_XRStreamingPluginIssue
Description: 2. Could not retrieve round trip frame timing

 

After spending many hours on this, I am just tilted right now. 😞

Bizla
Level 3

This may be a long shot, But reading on reddit with someone who had similar error messages, they found disabling windows defender's (called windows security in later versions) realtime scanning solved their issue. 

While their "symptoms" were different, the cause could possibly still be the same. 

https://www.reddit.com/r/OculusQuest/comments/frhi5d/steamvr_wont_launch_when_triggered_through_ocul...

 

And there's a post here that vaguely describes "stripes" appearing on screen, with some things to try. 
I have seen a lot of people recommending disabling XMP in BIOS fixes various issues around oculus link.

https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/White-horizontal-stripe-across-screen-while-...

Bizla
Level 3

I'm also wondering if your overclock could be causing an issue,  at least to rule it out, it may be worth running these tests without overclocking your CPU, and then once it's fixed, try re-enabling your OC. 

Bizla
Level 3

I'm going to be out for the rest of the day, so my attempts to help will come to an end (at least until this evening).  
But one more thing worth trying, in ODT try disabling ASW (it's the spacewarp technology that purposefully skips frames and extrapolates the missing frames) and cranking up the encoding bitrate to something higher than 300 to eliminate the chance of compression artifacts messing with your testing. 

weenan
Level 4

Do you get the same studders using Virtual Desktop?

VRdeadsec
Level 2

I notice the same problem. Consistently in steam version of Beat Saber making it unplayable. I have a laptop RTX 3060 with Ryzen 5800H. It happens less often on Virtual desktop but the graphics quality is lower and latency feels high.

I should also add that I tried disabling Windows Defender real time protection, and keeping the oculus console in the foreground, neither helped 😞

Anonym42
Level 3

Additionally to the changes I have made yesterday, I have now

- disabled Windows Security Realtime Scanning

- checked for XMP in BIOS which was disabled already

- disabled CPU OC in BIOS

- checked ASW (disabled already)

- set Encode Bitrate to 400

- tested the configuration using Airlink and Virtual Desktop


I had to set the Encode Bitrate to 0 again since the performance was worse even without having SteamVR started.

Tested again after setting back the encoding to 0.

Same behaviour in SteamVR / ingame; maybe even a bit worse than yesterday.