cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 stuck on meta logo after some sort of download

jgtkd
Level 2

At start up a download symbol appears, something downloads and then the Meta logo pulses for hours.  Stuck there.   I tried hard reboot and factory reset.

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Uh-oh, let's get this checked out and get your headset running properly. We also want to thank you for attempting troubleshooting prior to reaching out to us, much appreciated. Please submit a support ticket so one of our lovely agents can take an in-depth look into your headset situation so we may get you closer to a possible solution. https://metaque.st/Support 

graeme647
Level 4

Same here, just logged a ticket, looks like Meta are bricking their devices again

Hey there, thanks so much for going ahead and sending us a support ticket! Getting stuck on the logo at startup is definitely not the experience we want you to have, and we really appreciate the troubleshooting you've tried so far. We'll be back in touch with you on your ticket soon to make sure we help get you back in the game!