cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 with Link Cable keeps disconnecting and reconnecting

theAstra
Level 3

I'm having an issue where every time I try to activate link, it goes to the three loading dots and kicks me out back to the Quest home after about 10 seconds alongside my system spewing disconnect and reconnect notifications. I have an ASUS ROG Zephyrus G14 that has an RTX 3060 and a Ryzen 9 5900HS, so hardware is not a problem. I've been using the official link cable ever since I got my Quest 2 at launch, and according to the connection test from the desktop Oculus app it is still functional. I've even been able to play with link on this laptop before, so I don't know why all of a sudden it would start being difficult like this. I've tried every remedy I could find, ranging from reinstalling drivers, the oculus app itself, changing cables, changing graphics settings, and more.  Any ideas on how this could be fixed?

1 ACCEPTED SOLUTION

Accepted Solutions

theAstra
Level 3

Despite Oculus Support not finding a solution to this, I did some digging and found one! With modern laptops, there is a dual GPU setup, one integrated, the other dedicated. We want oculus link to run on the dedicated one. I tried doing that through windows graphics settings, but this did not work. But what if we *force* it to go to the dedicated card? I found out that by disabling the drivers for the integrated cpu graphics would force the laptop to run off of the dedicated card, therefore forcing oculus to run off of it too. Hope this works for you guys too!

 

EDIT: Adding onto this, after launching link with the drivers disabled, I have found you can safely re-enable them after the initial successful launch so the dual-gpu setup can still be utilized

View solution in original post

5 REPLIES 5

photomatt13
Level 2

following, my started doing this today

ObiEdge
Level 3

Glad to know I'm not the only one. Happened to me as well. Used it right before I went to bed, and woke up to this issue the next day. Not sure if there was a small SW update on the Oculus SW or the Quest 2 overnight but something broke the Oculus Link. Air Link no longer works either.

theAstra
Level 3

Since this thread is inactive, I have sent in a ticket to official Oculus support. I'll report any potential fixes here.

theAstra
Level 3

Despite Oculus Support not finding a solution to this, I did some digging and found one! With modern laptops, there is a dual GPU setup, one integrated, the other dedicated. We want oculus link to run on the dedicated one. I tried doing that through windows graphics settings, but this did not work. But what if we *force* it to go to the dedicated card? I found out that by disabling the drivers for the integrated cpu graphics would force the laptop to run off of the dedicated card, therefore forcing oculus to run off of it too. Hope this works for you guys too!

 

EDIT: Adding onto this, after launching link with the drivers disabled, I have found you can safely re-enable them after the initial successful launch so the dual-gpu setup can still be utilized

View solution in original post

Original comment was added to the answer, ignore this one lol