cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 with a 1060 3gb Guide

Indoorjoker
Level 3

Hi, so everyone here seems to think a 1060 3gb isn't VR ready, it is. The Quest 2 just doesn't like it.

 

Let me begin with saying a 1060 works fine with the rift s, generally you'll have zero issues playing even half life Alyx on low to medium settings. Unfortunately for me, the rift s I had needed to be returned after a week of having it since the cable just stopped working. Why don't I just replace the cable? Because Oculus is not making them anymore to faze out the rift line up. A cable costs more than the headset itself in some areas. At that point I decided to concede and get the quest 2 after I returned the rift s because it was the same price but better specs. And since the cable broke so quickly I was still well in the return time. Bought a cheap well reviewed link cable and thought I was good to go, nope. Half life will go from playable to won't work unless you halve the resolution and even then enjoy the frames dropping to the 20's after a half hour or less.

 

There's nothing wrong with a 1060 3gb for VR, but on the Quest 2 you can't really play extreme triple a games like medal of honor or half life. Let's be honest no one can play medal of honor. But still, I'm 100% sure this is on oculus for this one, switching from display port to USB-c only on top of the android OS only seems to be nothing but a huge issue and limitation for the platform in the long term.

 

Even then, it could just be me and my cheap cable as not all cables are built alike. I get 815 Mbps according to oculus test software when it should be around 1.8 gigs with the official; but I can't exactly just go buying up cables to test them. So this is basically what I did with what I had.

 

In short, here's a series of options/steps you can take to enjoy your quest 2 link with a 1060.

  • Make sure oculus test software adequately rates your cable speed and says it's good to go, if it's too slow you're done before you've even begun. To test a cable's speed just open the Oculus PC app and go to: Devices >> Quest 2 and Touch >> USB test. I get about 815mbs with a ryzen 3600 and asrock pro4 mobo.
  • If the port you use the cable in doesn't say USB 3.0 in Oculus App then flip the USB C connecter at the PC or move to a different port if using USB A. Keep trying till it will accurately test it. There's a half hour of headaches saved for later.
  • In the Oculus App go to Devices >> Quest 2 and Touch >> Graphics Preferences and set everything to as low as it will go, 72Hz, .9x render Resolution.
  • In the Oculus App go to Settings >> Beta and opt in for the public test channel; who knows maybe an unreleased update will do wonders. For me this upped my link speed to 1.1 gigs, an absolute must because this basically solved a majority of the issues.
  • If your using Steam VR Games then go ahead go to video settings in the Steam VR overlay and lower the resolution there on an application to application basis. Go as low as your willing. But this won't be necessary for most games. You'll need to find out for yourself what works and doesn't but turn everything off or low and disable Steam Home.
  • Now next up is a janky fix that might work for some, it made minor improvements for me personally. Open up all your stuff including Steam VR/the game you want to run better and set it aside. Press ctrl + shift + escape to open task manager. Then find OVRserver, steamvrserver, and the game your running in processes. Do this for each program, right click and go to details. Then right click the highlighted program again and click Set Priority >> High or Realtime. This one's annoying as you would have to do it each time you want to play.
  • If you're link cable isn't staying connected or is shutting off after a while you might need to change your power plan and some device options. First open control panel by searching for it with the search box in the bottom left of your desktop. Then, go Hardware and Sound >> Power Options >> click High performance then change plan settings >> change advanced power settings, and make sure in the pop up that follows to disable USB settings >> USB selective suspend setting. afterwards right click the start button, open device manager, and go down to Universal Serial Bus Controllers. Make sure you open each item in the drop down and go to the tab for power management then uncheck the box that allows the PC to turn off the USB to save power for all the items listed.
  • Now finally, this might not fix anything at all but try going into NVIDIA control panel and make changes to the manage 3D settings tab. set power management to prefer maximum performance, virtual reality pre-rendered frames to 1, and threaded optimization on.

Beyond that your at the mercy of your PC for your Link. If your still not satisfied with the performance you have one last option. But you'll need: $20 and an ethernet or WIFI 6 connection (AC or AX 5Ghz). If you have that go to this step by step video that addresses problems and ways to increase performance, 

Virtual Desktop Setup Guide: https://www.youtube.com/watch?v=Kk1IHDUnsAQ

 

This is all the info I have gathered thus far after 6 hours of non-stop troubleshooting and spit-balling. Virtual Desktop doesn't work for me but if you have a good connection people say it's almost better than the Link. If you're not stuck with your poor decision making and don't yet have a quest 2 buy a rift s. But be warned, BABY THAT CABLE. If it breaks you're out of luck. Otherwise wait and upgrade your GPU to one on their supported list if you want the long term support the quest 2 offers.

 

Good Luck, Have Fun, and don't feel like jumping off a high rise building thanks to this small guide.

1 REPLY 1

Indoorjoker
Level 3

I ended my fix-it escapade with completely 1:1 experience with my rift. my settings are as follows,

.9x resolution rendering - 2784 x 1408

72Hz refresh rate

 

In Steam VR: 

global resolution scale set to auto I edit on an app to app basis
Half Life Alyx

Resolution scale set to 70% or 1304 x 1336

Motion Smoothing: Disabled

In Game: start from low then customize to add, cloth physics on, flickering lights on, particles medium

 

Stable frames looks great and I can't tell the difference. all on a 1060