cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest says it's corrupt

TeamCoolKats
Level 2

When I try booting up my quest, it says that the device is corrupt and can't be trusted. I think what caused this was when I was updating but the update got stuck for hours so I factory reset. After the factory reset happened, the message started appearing every time I tried booting up. I've tried factory resetting many times since then but it hasn't helped. Once I'm past the screen that tells me that the device is corrupted, the quest seems to function as normal. It functions like a normal quest. That is until I try to connect it to my PC and play some PC VR games. The quest connects but the screen blacks out and kicks me back out to the quest home screen. It would be greatly appreciated if I can get some advice on how to fix my quest. Trading my quest in is probably not gonna be an option since it is a few years old. Thank you

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there TeamCoolKats, we always want to make sure players can play the games they want. We'll do our absolute best to you back into the game again and get your Oculus experience up to 100%! Below we've outlined some troubleshooting steps you could try to ease any potential link issues.

 

 

Are there any updates to Windows/GPU/USB?

 

Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but applies to Quest/Quest 2 as well.

 

For Windows, there's an article on how to check for updates here!

 

If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.

 

 

Game Mode may conflict with some VR applications.

 

In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.

  • Open the Windows Settings menu
  • Click on Gaming
  • Click Game Mode
  • Toggle Game Mode off

 

Submit a Support Ticket.

 

Collect Oculus Diagnostic Logs and submit them in a support ticket here so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.

 

 

If you have any questions, we'd be happy to help! Cheers!