cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Remote Desktop not connecting for Horizons Workrooms

Stellarat
Level 3

I have got Horizons Workspace working fine on my Quest 2.

 

And I also managed to get the Oculus Remote Desktop to work on my laptop so that I can see it's screen at my virtual desk.

 

However, I cannot do the same for my actual desk PC. Oculus Remote Desktop runs and logs in just fine, but it does not find the headset and the headset does not find it.

 

All the devices on are on the same network. My desk PC is high spec and has been working with Air Link just fine.

 

I also made sure that Air Link and (the third party) Virtual Desktop were not running so as not to confuse things.

 

Any ideas?

17 REPLIES 17

jdice34
Level 2

I've tried uninstalling, and re-installing on both my desktop and Oculus Quest 2. My computer is visible in the desktop app, and quest app. But when I try to connect, it immediately disconnects. 

Could it be something with Windows Defender Firewall, or Google WiFi?

whoisvince
Level 2

Same issue and at-least 6 other people with Quest 2's and Macbook pros like me also can't use remote desktop either  😞

reekotubbs
Level 2

I was told by support that it has to do with my Oculus account merging with my Facebook account. The troubleshooting steps they had me attempt has not worked yet though. Support stated that it looks like I'm logging in with my Oculus account and not my Facebook account and that is the issue.

 

The OP is showing that the issue can occur on one device and not another. Mine is failing on a laptop, I will try on my desktop pc.

Caldwyn
Level 2

I have tried this on 2 laptops (I don't have a desktop PC) if that matters.

 

For those seeing a 'no device available' message, I am able to re-pair the Oculus (and see it in the desktop app as 'ready' with the yellow dot.) That part is connectable for me by logging in to the workspaces.com site and clicking my name on the bottom left. The settings menu option has a choice to pair the Oculus Quest.

 

The problem is that I still can't get it to work.

 

Inside the Oculus workrooms app I can see my computer name to click. It just spins and gives up saying it can't connect to the PC. Strangely, the Windows 10 app shows 'connected' (green dot) while it spins, but then disconnects and goes back to the ready yellow dot it started with.

 

Just in case it was a windows firewall issue, I also enabled inbound and outbound communication in both 'private' and 'domain' settings for testing. I am doubtful that 'public' is needed, because I am on a private network so that is not something I cared to try anyway.

taopaipai81
Level 2

Happens the same here, i have reinstalled so many times, that i actually i losed the hope, if is an account issue is really shamefull cause they demand to use your fb account, but is installed on oculus account.

Dang, so many engineers and 4 weeks aprox since installed and no update on this issue.

Oculus_RyanS
Oculus Community Manager
Oculus Community Manager

Hi everyone! I wanted to let you know that the team is looking into this issue around some trouble with Remote Desktop not working right for Horizon Workrooms. I don't have a set timeline to share right now on a resolution, but the team is aware, investigating, and working on a resolution.

 

I'll let you know if there's any steps we need to have tested out or if you need to do anything on your end. 

 

I'm going to mark this message as the "solution" to this post so that it gets highlighted here.

View solution in original post

bodobear
Level 2

Hello, Workrooms is running perfect on my Quest 2, got a Workroom on workplace.com and the Remote Desktop App is paired with my account but also getting the following message: "No available devices. Open workrooms on your headset to connect."

Reinstalled the app, checked my network, firewall etc. with no luck.

 

Stellarat
Level 3

My Desktop app got updated on Sept. 17th but unfortunately my Desktop PC is still unable to connect to my headset, whereas my laptop can. I have tried logging out and setting up the connection using the code again, but that didn't work either.