cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Remote Desktop not connecting for Horizons Workrooms

Stellarat
Level 4

I have got Horizons Workspace working fine on my Quest 2.

 

And I also managed to get the Oculus Remote Desktop to work on my laptop so that I can see it's screen at my virtual desk.

 

However, I cannot do the same for my actual desk PC. Oculus Remote Desktop runs and logs in just fine, but it does not find the headset and the headset does not find it.

 

All the devices on are on the same network. My desk PC is high spec and has been working with Air Link just fine.

 

I also made sure that Air Link and (the third party) Virtual Desktop were not running so as not to confuse things.

 

Any ideas?

88 REPLIES 88

We understand you're getting an error message when trying to use your Oculus with your MacBook Pro. As it stands, Oculus devices aren't compatible with Apple computers. You'll need a PC running Windows 10 for your Oculus device to work as expected.


This thread is about Workrooms and using Oculus Remote Desktop to view our computers' screen in it. AussioLeo is not talking about running Oculus VR programs on the Mac, they are talking about running the Mac version of Oculus Remote Desktop (which exists) and connecting to it from Workrooms to see their Mac's screen.

kgea
Level 3

For the Mac M1 Oculus Remote Desktop app. Are there any ports that I need to open on my computer that another program might be using or create a port forwarding rule on my router for it to see my headset?

 

In the meantime, I'm hanging in anticipation for the update to be released. 🙂 

Why would you mark this as having a solution?  You have done nothing yet!

Oculus_RyanS
Oculus Community Manager
Oculus Community Manager

Hi andrewP777, as noted in the solution that's marked:
"I'm going to mark this message as the "solution" to this post so that it gets highlighted here."

This is done so the reply gets elevated and is easy to find, it doesn't indicate the status of the work currently being done. When there's an update available, we'll let everyone know and highlight that post instead.

Is there any update on this? A month seems like plenty of time to have identified a solution or at least sourced part of the problem. Thanks!

andrewP777
Level 3

I can get it to work on my laptop, but not my desktop.  It does not find the device.  It seems a common theme that the desktop PC is not working, but laptops are.  Why don`t they start with that?  What are the differences between laptops and desktops that would cause this problem?  These support people taking months to fix a problem is crazy.  Maybe they are in the wrong careers.

The team is testing out a build now which has some improvements for Oculus Remote Desktop that should help resolve some of the main connection issues, I don't have a specific timeline that I can share, but as soon as it's out I'll let you all know! 

I tried to reinstall, but it did not work for me 😞  When are they going to start working on this problem?

I'd like to suggest that in addition to trying to fix the issues that cause the connection problems, that it would also be good to have some kind of indication in the program as to what's wrong. Currently, if you can't connect there is no indication at all of why not, which is very frustrating for the user.

You have to read between the lines in this one.  The first red flag: have you ever seen a compatibility issue (in this case compatible with laptops, but not desktops) where the support does not even ask about what operating system you are using?  Not one time in this thread did they ask.  They do not even have the basic information to solve the problem!

Red flag number two: In every forum in the world, marking a ticket as solved does not actually flag the ticket as a priority.  It closes the ticket.  So Oculus support forum is different than the thousand other companies in existence?

I believe that the true problem is that Horizon's Workroom only works with built in video cards.  (Intel)  That is the only difference that makes sense.  Desktops have them... and most laptops do not.

I have created a partition on my computer and loaded a completely different Windows 10 than my original.  It does not work on that new Windows 10.  I use the same account on my laptop as my desktop, so there are no "you are using a Facebook account when you shold be using an Oculus account" if support is telling you this, it is because they do not want to publicize that it is not compatible with any high end video cards.

If anyone has successfully logged in with a high end video card, let me know.  Then we can do other trouble shooting.  Unfortunately, you cannot believe anything these support guys have said.