Showing results for 
Search instead for 
Did you mean: 

Oculus Rift CV1 not displaying anything- VCRUNTIME140.dll was not found

Level 2
(I have already solved this problem, just posting this for the sake of anyone else who has the same issue)
So I was using my headset as normal, and I went to do something, came back and my headset wouldn't display anything.
Tried all the usual troubleshooting steps:
-Unplugging and plugging in in headset
-Restart Computer
-Update Windows
-Update graphics drivers 
-Reinstall oculus app
-Reinstall steamvr
-Rearrange usb configuration
-Reseating cable into headset
(If you haven't tried these yet they are worth a shot)
But whatever I did, nothing would get my headset to display anything.
Through going into setup I could see that my sensors and controllers were working, but the headset still wouldn't display anything (even though the orange LED went off when I put it on, Indicating that the proximity sensor was working.
What lead me to my solution was an error message that would occasionally show up
"The code execution cannot proceed because VCRUNTIME140.dll was not found. Reinstalling the program may fix this problem."
(In my case it was VCRUNTIME_1.dll)
After hours of trawling internet forums I finally found a solution on a steamvr discussion board,
[Try searching "SteamVR preparing to run but does not run" (I cant make it a link yet due to not enough karma, may update) There is a good solution in there by Omar Boutros-Ghali]
Turns out VCRUNTIME140.dll is part of Microsoft's Visual C++ and somehow my version had messed itself up.
This can be fixed by uninstalling and reinstalling Visual C++ (I did this for all versions of Visual C++ just to be safe)

How to uninstall is a google search away but it works using the same process as most windows apps.
To reinstall, try searching "The latest supported Visual C++ downloads" (Again, no link)
After doing this the oculus app worked immediately for me.

Hopefully if this ever happens to anyone else they wont have to spend hours trying to solve it 🙂

Level 2
  • uninstall all MS C++ runtime libraries of the system
  • restart Windows
  • install the MS C++ 2015 runtime library x64 (see above)