cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift Headset Sometimes Won't Detect USB 3 - Reads It as USB 2

SilverMountain
Level 2
I've had this problem over the last week now, and I don't know what's caused it. I've plugged the USB for my headset into all 4 USB 3.0 inputs on the back of my computer, yet every time the Oculus program warns that the headset is plugged into a USB 2.0 port - up until I was making this exact post. I followed the recommended setting to shut down the Oculus program and run the oculus-driver.exe program in Program Files>Oculus>Support>oculus-drivers.

But that's not all, for I tried this fix just a few days ago as well, and it still said the headset was connected to a USB 2.0 port. I don't understand why it only worked now?

I'm using the Oculus app version 17.0.0.183.462, is this fixed in any possible beta versions of the software? What can I do make sure this won't happen again in the future, just run the oculus-driver.exe program?
1 REPLY 1

ceasare
Level 2
Same here..  running my oculus obsolete..... It worked flawlessly for a year...Removed and Installed all again but no success.....