cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S Controllers and Headset Stop Tracking and Freeze After a Few Minutes of Play

Altairibnlaahad
Level 2
After about 5 - 30 minutes of play, my Oculus Rift S headset and controllers stop tracking and freezing in place in-game. I've tried everything including reseating the headset cable, reinstalling Windows, repairing the software, banging my head against a wall, completely uninstalling and reinstalling the drivers, etc. I read another post about this same problem about buying a PCIe USB 3 hub, but I'm hesitant about buying something that may or may not work. Is this my only option left or has anyone else experienced this issue before? Thanks in advance!
8 REPLIES 8

Andrewe1
Level 3
some users report that using an external powered usb 3.0 helps, pcie card at this point is definitely hit or miss, see here for more info.

Other than that, a lot of us are in the same position without any help from Oculus

Badstar25
Level 3
I had tracking problems because of the lack of light in my room at night! I also had this type of problem with too much sun through the window. So I play with the light on and I close the shutter when there is too much sun.

FaCars
Level 3
my spec

CPU : AMD Ryzen 1600x
RAM : 16 GB
Graphic Card : GTX 970
Motherboard : Fatal1ty X370 Gaming K4 
( it have USB 3.1 Gen2 Type A and C , 5*USB 3.1 Gen1 , 1 Fatal1ty Mouse Port )

(im not good at eng so my grammar surely not correct)
I had this problem before ,im bought it 1 month after it came out so i play about 10-20 min and my controller stuck in the air as everyone ,until yesterday i tried usb port that design for mouse its for gaming mouse and it work perfectly i can play for about 3-4 hr without problem.
in that case i think its possible that my 3.1 Gen2 type A port and other usb are broken or not enough for minimum requirement like power or data transfer rate.

kojack
Volunteer Moderator
Volunteer Moderator
USB3.1 Gen 2 have been known to be problematic. On my Asrock Taichi motherboard the single USB 3.1 Gen 2 port results in broken force feedback on the Rift (it happens delayed or turning on or off at the wrong time), but the USB 3.1 Gen 1 ports are fine.
I also run through a powered USB hub, which helps.

Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Altairibnlaahad
Level 2
I was able to (hopefully) fix it! I found a usb 3.0 hub and plugged the Rift S into that and so far so good! I only had enough time to play for about 20 minutes but that's still longer than it's worked in the past. I'll post an update about extended play time later today

Altairibnlaahad
Level 2
HAHA I was wrong, it didn't fix it lol

Schpudz
Level 2
1. open system information
2. click control panel
3. system and security
4. system
5. device manager (should be on the right side of the window)
6. Find Universal serial bus controller
7. right click on the usb port your oculus gets plugged into
8. click properties
9. go to the power management tab
10. uncheck the box that says "Allow the computer to turn off this device to save power"

The controllers shouldn't freeze up now. I think the problem comes from the motherboard not realizing the usb is in use so it flickers the power to the USB off and on causing an error in Oculus' software.

Freejack77
Level 2
This did not fix the issue on my side.