cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S No Video After Firmware Update 7/5/2019

Gman8336
Level 3
I am so disappointed. Oculus software said update required.  After the update successfully installed I have no video whatsoever in headset. Tried to perform setup, still no video in headset at all.  What the heck???
3 REPLIES 3

Fangzhou
Level 6
I faced similar “black screen” issue before, fixed after a re-plugin of DP and USB and restart computer. After upgrade to 1.39 patch I have never get black screen issue yet..

ElusiveMarlin
Level 7

Did you apply the device update also?

I performed the Oculus update but didn't get round to using my HMD until the next day, and when I put my headset on, all I had awas a black screen and two amber LEDs.

I forgot I'd performed an update the previous day, so I launched the Oculus desktop software, and low and behold, I see a red banner at the top asking me to perform device updates. 

Once I did that everything returned to normal functionality.


RIFT CV1
RIFT S
Leeds, UK.

Intel Core i7 7700K 3.7GHz | RAM 32GB DDR4 2666MHz | GeForce GTX 1080 8GB |

"Behind every mask there is a face, and behind that a story...."

Gman8336
Level 3
Yes, I also did the device updates. I had to remove and reinsert the DP and USB cables as Fangzhou stated and that worked but now it has happened again.  I never had this issue with the original Rift or with the Rift S until this latest update. This is a bit of a PITA.