cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S keeps crashing

Xxblur
Level 3
Hi, I recently bought the rift s and the applications keep crashing about 10 min in even when im just on the home screen looking around. Audio would give a small shriek and then black screen with the led turning orange. Sometimes the application I have open would also freeze on the pc screen. I know my pc is compatible (rtx 2070 and amd threadripper processor), all my drivers are up to date and same as OS, i tried uninstalling and reinstalling oculus, and changed the usb setting as well for the blackscreen fix but nothing is working. Please help 😞  
9 REPLIES 9

harveysimpson39
Level 3
Same here and same GPU as you 

Robotwatermelon
Level 2
I'm getting the same results... I have done literally everything I cam find to help it but the video just cuts off about 10 seconds in... I cant even set it up... I literally preordered this device the day it was announced so ive waited for forever for this... btw I have the MSI GE63, Nvidia GTX 1060, I7-8750 processor. On top of all that I have done multiple VR performance tests and my laptop is well capable of supporting this... PLZ help oculus

Xxblur
Level 3
Seems like its not only me who is experiencing this issue. I have submitted a support ticket to oculus with my logs. I will update this thread if I have found a solution. 

Xxblur
Level 3
Found a solution that seemed to work for me. I first changed my usb settings that was known to solve the blackscreen issue, then unplugged everything, uninstalled everything, and then reinstalled. Restarted comp then I plugged in the USB slot first and then waited about 5 sec to plug in the display port. Doing this seemed to solve my issue because i havent had any applications crash on me since and its been about 2 hours which is a new record for not crashing. Hopefully this works for you guys.

RiskyPoint
Level 2
I tried that but it doesn't work. I have tried basically everything.

RD909
Level 2


I tried that but it doesn't work. I have tried basically everything.



Same. I'm waiting for a new power cable from Oculus.
Alienware X51 R3 - Nvidia GTX 970

MAC_MAN86
Level 9
Tried AV=OFF and RUN programs then can be set ON again? It fixed THE CLIMB to work on both RIFTS.

azureus49
Level 2
Hello all were your problems resolved?
im just about to follow up on an order for an rtx2070, with a view to buying a rift s in the next few weeks.
should I get a vega 64 instead? I’m running a 1920x with all ram channels in an x399m.

cheers
jon

Stressfulbean
Level 2
it didn't work gamers this is dumb