cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift_S not woks on windows 11.

edaolio
Level 4

Any solution? (Please, reinstall windows 10 is not a solution. 

22 REPLIES 22

@TodAufDerFlutch  Sorry mate but all your points are pretty meaningless imho.  Win11 currently has the lowest adoption rate of any new Windows OS ever (still less than 9%) and most businesses are not planning to update for at least another year.  Win10 is fully supported until 2025 so there certainly is no rush to update to win11.

 

https://www.computerworld.com/article/3643074/windows-11-adoption-nears-9-but-businesses-are-waiting...

 

If you got a nice brand new PC you probably had the option (if you had actually asked) for it to come installed with win10.  Otherwise, it's a fairly simple process to roll back to win10 anyway.  You don't need to be a Windows expert to do this.  The Product keys are the same for both win10 and win11 so you can easily update to win11 later.

 

If you were silly enough to upgrade on your existing PC you have 10 days to roll back.  Surely this should have been enough time for Oculus users to identify issues by then and roll back to win10.  Otherwise, you're kinda stuck with what you have or you'll need to do a clean win10 install which I know is a royal pita.  Some programs may work ok and some will either not work or may have performance issues and possibly the odd crash.

 

Pointing the bone at Oculus, or other companies who have not managed to fully support win11 is completely unwarranted.  So many systems and drivers are not yet win11 certified and in the case of older ones, these may never be certified.  A few win7 users (not many of these anymore) continue to avoid win10 for compatibility issues.

 

But heh, feel free to rant about this for as long as you like, lol!

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

I know this is dated but I think the real meat of all of this is oculus/meta whatever they are called are taking no accountability in this. I have a rift s and they bricked it and did nothing except saying without saying "mmmmmm I'm soooooo sorrrrry. Buy the next headset and maybe we will make it up to you" the windows conversation means nothing to me as I won't upgrade yet but bro you can't seriously sit here and back up a company who made someone so frustrated and desperate as to hope the new OS would work. If it wasn't such a pain. I prolly! would've done it to but got too much on my ssd to wipe and start over. We just want our $400 to $500 of entertainment that were are owed. Is that so much. Lord knows if they gave us $500 their greedy asses would spend $1000 to get it back. Fix our $h/t Oculus.

Espionage724
Level 5

I was trying to see if Windows 11 would be an issue with a CV1, but couldn't get Oculus installed at all yesterday (kept failing Install and telling me to restart the computer). This was on 11 Dev build (22538.1000).

 

Went back to 10 LTSC and all is well again. It'd be nice if Oculus software worked on 11 for those who insist on using it, but imo 11 is still not ready for most people to casually use. Outside of Oculus, there's still inconsistencies with AMD CPUs and cache performance, and known performance issues with NVMe drives now which I ran into; was just like using a HDD. It's bad, I don't see what the hype is, and anyone waiting on Oculus to somehow make their software work on 11 is much better off just using 10, unless you're on Adder Lake I guess.

Quest 2 | 2700X | 6600 XT

A solution that needs to be deciphered is not a solution

So did you have to Install windows 11 in order to make it work? Forgive me I am confused and only know the basics. Well slightly above average. 

Did you have any luck? What I did and I'll retry it again later after I'm done playing as I don't want to miss this rare opportunity. But if you're getting the displayport instead of unplugging blah blah blah go into device managers and disable one of the rift ones. It'll be the one that wants you to restart the pc. Restart the pc enable it and update the driver when it asks if you want to reset the pc go to no. Mine has been working for the last 20 to 30 mins and I couldn't even get 5 mins out of it before. I'll try it again later to see if it's a good enough fix

Not everyone got it by choice...

edukras
Level 3

I will tell you that FORMATING and INSTALLING WINDOWS 10 is the solution, unfortunatelly. I had the same issue, and even sent my headset to Oculus for a replacement. After receiveing the new headset, I HAD THE SAME ISSUES WITH WINDOWS 11!!!!! That means my former headset had no defective!!!!

So I decided to format my SSD, replacing Windows 11 with Windows 10 and "voisla"! Now it's working fine, no more "sensors can't track"!!!

WarmJones
Level 2

so im not sure if anyone else has found a better fix but i did install a developer build windows 11 and my rift s does work on windows 11 now however there are some issues im slowly trying to work out... and to the few people who seem to think their PC and all others should only be used for VR are just trolls or idiots so everyone please ignore them. no sane person would actually think that the burden of reliant software should be on the consumer. if that was the case we would all be using linux lol.   

That would only be of use, if you advertised this doesn't work with windows 11, now debating weather to by a new VR system, guess which company never getting my money again. As if a tech company can't keep up, then it is not a very good tech company.