cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S not working even though the USB is plugged in

ImaWeeaboo
Level 2

So since April my Rift S has been showing as "not connected" on the app even though both of the plugs are in the computer. I have done everything to fix it. I got new cords like 3 months ago and it stopped working shortly after that. Is this a driver issue? I've looked at the Rift S drivers and uninstalled them and plug the USB's back in and it still doesn't work. I've tried updating the software, didnt work. Please help me.

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hi There! We understand how important it is to get your Rift S issue resolved. We are happy to be of assistance! 

 

Since it is not connecting for you, let's try out a few troubleshooting steps:

 

  • Ensure your PC meets the minimum requirements: (Minimum PC Requirements)
  • Connect the Headset to a different USB 3.0 port

  • Attempt using the Headset on a different PC 

  • Verify that your Headset and primary monitor are connected to the same video card 

Please review this article for further steps: (Rift S Headset not connecting). 

 

If you are still looking for a resolution after completing these steps, please submit a ticket here: (Support Ticket). Happy Friday! 🙌