cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S "No DisplayPort Connection"

high-tech
Level 2
Okay, here's the story: I got my Oculus Rift S as a Christmas gift in 2019. It was working good for a long time until one day I picked it up again and the displayport connection stopped working. I looked online for help but all the posts were about an update in 2019 so that didn't apply to me because this happened many months later.
I finally decided to go out and buy a new cable of the rift, and It still doesn't recognize the DisplayPort cable, only the USB.


What should I do?
5 REPLIES 5

OculusSupport
Oculus Community Manager
Oculus Community Manager
Hey, thanks for taking the time to work on this issue on your end, including buying a new cable. We'd like to help you out from here, can you please click here to submit a ticket? Thanks!

tailsld
Level 2
high tech welcome to a lot of peoples problem...there was an update for me today  yeah... didnt solve the display port problem.  i have a lot tied up in flight sim controllers...almost 6 weeks not being able to use oculus.

iDrika
Level 3
Same here. Can't use my Rift S since Xmas. Please keep us posted if you find a solution. Mine is mostly USB though, it only says it's the Display Port after I disconnect the USB. So bad. 😞 

chrisogrady
Level 2
I started playing today. I noticed a new version had installed when I started. I'm in the beta program.

All of a sudden after about an hour of play today I get "displayport connection not working" and "no displayport connection"

There is a white light on the Rift S.

I have tried to disconnect the rift cable on both ends several times. Restarted, shut down and restarted.

Just uninstalled Oculus and resintalled it.

I still have "displayport connection not working" in Red. Why is there a white light on the rift and an error that the cable is not connected?

I am also heavily invested in flight sims. I can't do this for 6 weeks waiting for a magical fix.

Is there any solution to this? I don't even know where I would be able to find another cable to test it...

chloe233
Level 2
Is there any solution? The same thing happened to me last month.  😞