cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S stuck in software restart required loop

Wilky926
Level 3
Hi all.  I bought an Oculus Rift S to replace my original Rift yesterday, set it up and played with it all day with no issues.  However today it just will not work at all!  The Oculus home keeps telling me that it requires a software restart but every time I do this it just reboots and tells me it needs to restart again.  Also windows flashes up saying the headset is not detected every time I turn my pc on now and the setup for the headset gets stuck on the sensor setup part.
I have updated all drivers and downloaded the latest Oculus software and ran the repair and nothing has worked so far.  
A google search is revealing that this has been an issue since July!  but I cant find a definitive answer as to how to fix this.
Any help is appreciated because im 2 seconds away from sending this back and getting a HTC Vive lol.
216 REPLIES 216

robertoalba
Level 3
I have the same exact problem, I'm very worried because this is my first VR Headset

Kdozer
Level 2
The same exact thing happens for me. I'm a new user as well. I disconnect the display port and usb c and it comes back temporarily. is this a bug?

Mizcreant
Level 3
I'm not a new user and this is happening to me too.  In fact, I can't even reinstall the Oculus software.

Killerchef9037
Level 2
This is happening to me as well,

Every time i shut down the PC the Oculus software says i need to restart the software and so on, i have to disconnect the headset then remove it from the device list on the Oculus software, I then have to do a complete setup again.

This is my second Rift S as the first was faulty, I have just given my headset to a friend who has one themselves to see if it happens to him with my headset as he doesn't have any problems

I had an original Rift which worked great.

Haideng
Level 2
I have the *exact* same problem. I'm not sure why it just suddenly stopped working. Really want an answer.

chris_forster_7
Level 2

Mizcreant said:

I'm not a new user and this is happening to me too.  In fact, I can't even reinstall the Oculus software.


I had the same problem. Since the last firmware update Wednesday of last week. Uninstalled like support said and now I can’t even reinstall it. This is the last email I got 3 days ago. Hey,

Thank you for trying that step.

Please give us some time to look into this further for you.

We will update you as soon as possible.

Mizcreant
Level 3



I had the same problem. Since the last firmware update Wednesday of last week. Uninstalled like support said and now I can’t even reinstall it. This is the last email I got 3 days ago. Hey,

Thank you for trying that step.

Please give us some time to look into this further for you.

We will update you as soon as possible.




Same here.  Provided logs, provided my system information.  I spent quite a bit of time detailing some very extensive troubleshooting steps.  I've been given advice to re-do everything I've already done, plus a request to forward ports. 

Forwarding ports of course wasn't required when I initially set it up, and doing it now didn't help either.  At the moment, our Rift-S is a paperweight.

The best part is it's not even connected to the computer.  The Oculus software refuses to install.

uKER
Level 5
This also happens to me, but is fixed by just unplugging the headset from both USB and DisplayPort before you click the "Update" banner.
This time the update will actually work and stop nagging you.
Same thing if you're performing a clean install of the drivers. Disconnect the headset until strictly necessary.

I've already tried to work this out with Oculus but not much was achieved I guess.

Kdozer
Level 2

uKER said:

This also happens to me, but is fixed by just unplugging the headset from both USB and DisplayPort before you click the "Update" banner.
This time the update will actually work and stop nagging you.
Same thing if you're performing a clean install of the drivers. Disconnect the headset until strictly necessary.

I've already tried to work this out with Oculus but not much was achieved I guess.



This only worked temporarily for me. The update required comes up after every reboot and other random times that I haven't been able to pinpoint a trigger.

System Information
------------------
      Time of this report: 11/28/2019, 10:19:02
             Machine name: ****
               Machine Id: {****}
         Operating System: Windows 10 Home 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
                 Language: English (Regional Setting: English)
      System Manufacturer: System manufacturer
             System Model: System Product Name
                     BIOS: 0905 (type: UEFI)
                Processor: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz (16 CPUs), ~3.6GHz
                   Memory: 16384MB RAM
      Available OS Memory: 16304MB RAM
                Page File: 8857MB used, 11157MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
           DxDiag Version: 10.00.17763.0001 64bit Unicode