cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Setup Restart Computer Error

jayklly
Level 2

The oculus app keeps failing to install and shows up with restart computer. I have tried restarting many times used and tried many forum solutions such as using regscanner to delete old registries, boot into safe mode and deleting oculus folders in many locations, using a different drive, using a different user account, and finally my own solution copying files with a known working install to my computer. The only option I think it could be is that I'm on windows 11 but I don't want to rollback.

3 REPLIES 3

Boingoo
Level 2

having this exact problem 

kif11
Level 3

I'm having the same problem. Not able to install Oculus software. Seams like it failing to install oculus-driver.exe since I'm getting the following in OculusDriverInstaller.log

 

[Debug] [9/27/2021 11:09:08 AM] Beginning installation of Monitor Driver - Driver package 'C:\Users\koval\AppData\Local\Temp\OculusDriverInstaller\RiftDisplay.inf'
[Debug] [9/27/2021 11:09:08 AM] DevPresentOnInstall = False
[Info] [9/27/2021 11:09:08 AM] DriverPackageInstall(DRIVER_PACKAGE_ONLY_IF_DEVICE_PRESENT) result: ERROR_NO_SUCH_DEVINST - Device not detected (not plugged in) right now
[Error] [9/27/2021 11:09:08 AM] DiInstallDriver() error message: The certificate is not valid for the requested usage
[Debug] [9/27/2021 11:09:08 AM] Ending installation of Monitor Driver
[Info] [9/27/2021 11:09:08 AM] FAILURE! Failed to install driver: Monitor Driver

 

Other driver packages failing with the same error. Can not attach the full log here since this forum post is limited by 20000 characters.

kif11
Level 3

I was able to finally install the driver by rebooting in "Safe Mode". I guess the reason why it worked is because in safe mode Windows doesn't check drivers certificates.