cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Virtual Audio device missing.

LeShaDDoW
Level 3

I dont get any sound in VR with oculus Link and the oculus virtual audio device is completly missing.

It worked for a long while but not anymore.

YES I tried looking if its disabled.

YES I tried restarting my Quest 2.

YES I tried restarting The oculus app.

YES I tried restarting my PC.

YES I tried using the oculus device Audio settings.

YES my Oculus App AND Quest 2 has the latest updates.

YES I tried repairing / reinstalling Oculus.

Before all of this happened I had a Problem that oculus Link didnt work at all.

My Specs (In case you need it.)

GTX 1650

8 GB RAM

AMD Ryzen 5

4 REPLIES 4

Ozzbik
Level 4

Could you put the actions in the order you've actually followed (like uninstall -> restart windows -> install oculus app etc.)?

First oculus stopped working.

Then I fixed it.

Then another problem accoured I dont actually remember what it was.

Then I uninstalled and reinstalled oculus

Then the sound problem acoured. >> restarted Oculus >> restarted Headset >> restarted my PC >> tried solving it.

I dont really want to reinstall the app again, because my internet speed is like 400KB per sec. average.

Ozzbik
Level 4

So the Oculus Virtual Audio device does not show up as a Audio input and Output device in Device Manager?

You can try to manually add it by installing a new "legacy" device.

In the Device manager are the following steps:

- Click Action

- Select Add legacy hardware

- Click next

- Install the hardware that I manually select from a list (Advanced)

- Select Show All Devices

- In the Manufacturer list select Oculus

- In the Model list select Oculus Virtual Audio device

And finish the install.

Reboot to see if this helped.

It somehow fixed itself already.

I don't know what I did but it shows up again. I hope it works now.