cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus XRSP Interface (USB device not recognised)

Eurostar27
Level 3

I have been spending a huge amount of time trying to get my Oculus Quest 2 Link to work.  Oculus Support says there is no more they can do?  This after uninstalling and reinstalling USB Hub and Root Hub Controllers,  uninstalling and reinstalling Oculus Software, plus the PTC. Reset the Quest 2 headset.   Updating ALL the ROG Maximus XIII Hero Asus/Intel drivers, Nvidia Drivers. Disabling USB Power Management. Disabling 'Thunderbolt' on the USB-C ports in the Bios et, et. I have checked in the 'Device Manager' and the Quest 2 is listed as 'Oculus Device'/ [!] Oculus XRSP Interface.  The driver does NOT update (best driver found)? BUT this driver is causing a conflict? Even though the Oculus Link charges the Quest 2, a box appears when connecting 'USB device not recognised'  This has to be a driver problem, not the brand new hardware (motherboard), as Oculus Tech have suggested?  THERE MUST BE A FIX FOR THIS?   COME ON OCULUS, PLEASE PLEASE HELP ME.

2 REPLIES 2

SkeptiCrow
Level 2

I have similar problems with:
Intel Core i9-10900KF
MoBo: ASUS Strix Z490-E Gaming - OS: Windows 10 Pro 64-bit

I did tons of steps like the above, the thing that seemed to finally make a difference was connecting a Quest 1 - it worked fine... then afterwards, my Quest 2 connected okay.

IDK WTF!

hunnikin
Level 2

I have exact same issue with AMD X570-E ROG Strix board. Oculus support tried everything. I don't have the time to keep messing about with this dud driver. Its been six months.  Likely sell it and try another VR system.