cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus button no longer display Dash in any apps; "Oculus App Runtime isn't responding" on startup

UpUpDnDn
Level 3

Ever since I received the last update to the system software (version 41.0.0.124.268) on my Quest 1 a few days ago, I cannot display the Dash menu in any apps when I press the Oculus button on the right controller.  Many apps don't have an Exit or Quit option, so this means I have to restart the headset with the power button to get back to the home menu which takes a long time (see below).  The physical Oculus button is definitely working because it toggles the Dash in the home menu and I can hold it down to recenter my view in apps.

 

I also have another issue that may or may not be related.  Every time I boot or restart the headset, after 1-3 minutes I get an error message that says "Oculus App Runtime isn't responding" with options to Close App or Wait.  After choosing either option, the passthrough and guardian appear about 20-30 seconds later and everything seems to work normally after that (except for the issue with the Oculus button).

 

Is anyone else having either of these issues, and is there anything I can do about them other than wait for the next system update?

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Hey there, @UpUpDnDn! We know how important it is for the dash to pop up properly when pressing the Oculus button, so we'd love to help out!

 

In regards to the Oculus dash, could you please answer the following:

 

  • Have the controllers ever been mishandled? (Dropped, tossed, spilled liquid, etc.)
  • Have you attempted any troubleshooting for this? 
    • If so, please list them out so to not repeat anything.
  •  Does the issue only happen when in games/apps?

 

As for the Oculus app runtime error, please see below:

 

  • When was this first noticed?
  • When you reboot the headset, is it through the boot menu by holding the power and volume down buttons together?
  • Have you attempted any troubleshooting for this issue as well?
  • To confirm, it happens roughly 1-3 minutes upon startup?

 

Once we have these answers, we can look into some other possibilities!

I tried some more troubleshooting and encountered an even stranger error.  I usually select Wait on the error dialog on startup since that seems to work a little faster, but that seems to result in the issue with the Oculus button not loading Dash.  However, if I select Close App, wait for the home menu to load, then launch an app or game, the Oculus button does display the Dash menu in-game, but after I quit the app I end up with two menus in the home environment as shown below:

com.oculus.shellenv-20220710-160121.jpg

Also, if I am in an app that uses hand tracking and I point my palm at my face, the Oculus logo doesn't appear and I can't pull up the Dash menu with the pinch gesture.  The hamburger menu icon does appear on my left hand when I do the guesture though.  This is further indication that it's an issue with the system software rather than the controller itself.

 

Here are some answers to your questions: 

  • The controllers have been bumped into furniture a few times during use but have worked normally until this issue.
  • I replaced the battery in the controller, I didn't think of any other troubleshooting steps.
  • The Oculus button always toggles the menu in the home environment.  If I select Wait on the error dialog during startup, the button does not show the Dash menu in games/apps.  If I select Close App on the error dialog then the button does show the Dash menu in games/apps but I end up with 2 menus in the home environment.
  • The startup runtime error started appearing a few weeks ago, possibly around the time I received the v41 update but it may have started even before that.
  • When I am "stuck" in an app I can hold down the power button for 4 seconds to show the Cancel/Restart/Power Off menu and restart the headset that way.
  • I have also tried fully turning the power off and restarting several times.  I did not want to perform a factory reset unless the device becomes totally unusable.
  • If I boot the device from being powered off, the boot logo pulses for 2-3 minutes, then the screen goes black for a little bit, then the runtime error dialog appears (if I restart from the menu this part usually takes about 1 minute).  Usually the passthrough will turn on in the background within 60 seconds, but sometimes it just shows the gray grid background.  Regardless of whether I select Wait or Close App, the passthrough will display but the controllers won't appear or work for about 20 seconds, then the screen flickers and eventually the "Objects found in your space" message appears and I can proceed as normal.  Let me know if you need more info.

Thank you so much for this update.

 

As this seems to have happened right around v41, feel free to post it within our Ideas posts where our Developers look for inspiration for coming updates. Along with that, we suggest submitting a bug report as well.

 

The next best suggestion we could provide is attempting a Factory reset and then creating a support ticket through here where we can look at some other possibilities!