Showing results for 
Search instead for 
Did you mean: 

Oculus link cable and air link not working

Level 2

I got this link cable for my laptop recently and for some reason my computer refuses and i mean REFUSES to detect the cable, I constantly get "USB device could not be recognized, (Port reset failed)" and error code 43, I've tried literally every solution out there and none have worked, and before i got the cable I tried air link and all that would happen is that it would take me into the rift home, and freeze with these weird black and grey lines all over everything that move when i look around, and the menu is basically impossible to use, I got the Quest 2 to actually have a headset that works with my computer and it just won't work for some reason, it's incredibly frustrating. and I don't know what to do.


Community Manager
Community Manager

Hey there, Nexus! We appreciate you trying all those trouble shooting steps before reaching out, link cable issues can be so frustrating! Please submit a support ticket here and one of our agents will assist you in no time! Alternatively you can send us a PM by clicking here or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message. Hope this helped! 👍😁