Showing results for 
Search instead for 
Did you mean: 

Oculus link doesn't work for several months now. Oculus seems to ignore community problems

in september my oculus link stops working
Therefore i tried many solutions
All listed here:

uninstall/install oculus software on pc
uninstall/install many apps on quest2
reboot quest2
uninstall virtual desktop from quest and from pc
changed antivirus from invasive Norton to free AVS
update nvidia drivers
Flagout/flag in every experimental feature in both oculus and quest devices
came back to summer nvidia drivers


that frustrating man
I ve got ryzen9 and rtx 3080
i ve got a oculus official cable and another one fully functional

How could be possible that people spend so much money in a software house so less customer-care effective????


Community Manager
Community Manager

Hi there!


This definitely is not the experience that we want our users to have. I hate to hear that you are having issues with your Oculus Link.

Please reach out to our Oculus Support team via the included link and one of our dedicated care team members will help you get back to gaming!!


We are always eager to assist. 

Level 2

Mines never connected to my headset. 

Level 3

Have a ASUS ROG Trix laptop and I get the same issue .... And I succeed to workaround it byt doing the following...

From pc fresh boot

Login into a fresh Windows session

Open "Device Manager"

Search for "Display Adapter"

You should find 2 adapaters : 1 AMD and 1 NVidia

Select AMD then right click on it and select "Disable"

Wait that NVidia driver take over your graphical session  (maximum 10 seconds)

THen select AMD then right click on it and this time select "Enable"

After few seconds , all is return to normal

Boot you oculus Quest2

In VR : start "Oculus Link"

On computer : Oculus application starts as expected

In VR : the grey Oculus Link Lobby appear ( no more endless rolling 3 dots : environ 10 seconds wait at max)

From there you should be able to start your VR App/Game


From there, In VR, you may experience black "Virtual Desktop"

It' appear that if you assign "AMD" GPU to OVRServer_x64.exe  then you reboot your pc and do the "enable" "disable" process then the Virtual Desktop may be ok...



NB : The disable/enable process must be done once per fresh windows boot.


This tips work for me ... hope that may help you


Level 4

what you don't write:
which OS do you use?
is it an original Link Cable or a 3rd party?
did you try differt USB ports?
Is it showing up in device manager?
does the test on PC side say all ok?
did you try on a fresh Windows?
your mainboard
Tried reset the quest to factory?
installed firmware version?