cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link keeps crashing and showing up as an application

CubeyOculus
Level 2

When I boot up oculus link, it works fine for a few minutes, but then it crashes. Also, when I click the oculus menu button, oculus link shows up as an application. Does anyone have a solution to my problem? All replies are greatly appreciated.

 

Hardware:

CPU: Intel Xeon E5-1620 v2

GPU: NVIDIA GTX 1050 TI

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there CubeyOculus, thanks for reaching out. We see you are having issues with Oculus Link crashing after being connected for a few minutes. We're sure this is frustrating as you are unable to play inside the VR world undistracted so I will do my best to help you find a viable solution. 

 

We do have a couple of questions that will help us identify your issue:

  • Have you updated to the most recent version of Windows 10 or 11?
  • Is your computer a desktop or a laptop?
  • Are your drivers (USB, Graphics) updated to the latest versions? 
  • Has Oculus Link worked successfully on your computer before? 

We'd first like you to try repairing the Oculus app on your PC. 

To repair the Oculus PC app:

  1. Go to www.oculus.com/setup and click Download Oculus Rift software.
  2. Select Repair.
    • If Windows asks you if you’re sure you want to open this file, click Yes.

    • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.

    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.

    • Please remember to re-enable your antivirus software once you've completed the repair.

  3. Allow the repair process to run, download and install.
  4. Restart your computer
  5. Launch the Oculus App

Once these questions are answered and these steps are tried, we will have a better understanding of the issue you are having.