cancel
Showing results for 
Search instead for 
Did you mean: 

PC App and Headset are different versions

KingBoodaddy
Level 2

I'm not able to use oculus link cable because the versions are not the same. The PC App keeps saying there aren't any updates to, ver. (30.0.0.36.502). My Quest 2 is ver. (30.1.0.61.350.300158191). I've read that both ver. have to be the same in order to use link. I've uninstalled and cleaned perflogs and deleted folders, then reinstalled. Still get a different ver. than my actual headset. Any help?

7 REPLIES 7

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey, we'd be happy to look further into this with you. Could you please click here to submit a ticket and include your Oculus Diagnostics Logs? Thanks.

Please update Quest and PC at the same time. I'm not able to play Sniper Elite VR which launched today because of this!!

I have the same issue with the same ver. numbers, oculus link is not working please fix or post a solution

niknikz
Level 2

I'm having the exact same issue and my oculus app won't recognize the headset when I try to add device with the link cable.

PITTCANNA
Level 12

its really just the first 2 numbers that matter.

Now keep in mind if you are the beta in the pc app it might be ahead of quest pc app.

 

So switch the beta option off and on to determine if it can operate.

 

Now link could be disabled if you have enabled air-link in the experimental settings on the quest menu.

KingBoodaddy
Level 2

I finally got it to work!

 

On the PC app turn on Beta in settings

 

Then on your Quest 2 Headset turn off Air Link

 

Connect your link cable to the headset

 

On the PC app, go to add device and start the "connect your headset" sequence

 

Then restart your Headset

 

Your PC app will recognize the headset a little before it shows the home screen

 

Once the PC app says Headset found "test connection" put on your headset and click "Deny" for access files

 

Right after you click deny, the prompt for "Enable Link" will show up then click "Allow" 

 

You have to make sure all of these steps are followed in that order or it won't work

Yeah if you have air link enabled in the headset it prevents the physical link from operation.


@KingBoodaddy wrote:

I finally got it to work!

 

On the PC app turn on Beta in settings

 

Then on your Quest 2 Headset turn off Air Link

 

Connect your link cable to the headset

 

On the PC app, go to add device and start the "connect your headset" sequence

 

Then restart your Headset

 

Your PC app will recognize the headset a little before it shows the home screen

 

Once the PC app says Headset found "test connection" put on your headset and click "Deny" for access files

 

Right after you click deny, the prompt for "Enable Link" will show up then click "Allow" 

 

You have to make sure all of these steps are followed in that order or it won't work