Showing results for 
Search instead for 
Did you mean: 

PC reboots when starting Oculus Home on Core 2.0

Level 5
Hi. I'm on the Beta channel and since the update to Core 2.0 I'm getting hard freezes most of the times I open Oculus Home, requiring a restart (keyboard leds stop responding).
Also, something weird is that when it doesn't freeze, it does stall for several seconds and the "new hardware" sound is played, which it didn't do before.
Am I the only one?

Level 3
Same thing here. The second I start loading the program, I get a hard freeze for 10-20 seconds. Then it will intermittently unfreeze/refreeze until I'm forced to restart. Killing all processes related to Oculus does not solve the issue, only a restart.

I have tried reinstalling video drivers (Nvidia), uninstalling/reinstalling numerous times on different drives (an SSD and HDD). Also tried manually uninstalling the drivers for the sensors.

Only thing I could find in the Event Viewer about it was -

Warning,12/20/2017 7:08:09 PM,Microsoft-Windows-Kernel-PnP,225,(223),The application \Device\HarddiskVolume6\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe with process id 4696 stopped the removal or ejection for the device USB\VID_2833&PID_0211&MI_00\9&24a304b7&0&0000.

Level 3
Also been having freezing issues with the public beta build, mostly when going between headset to monitor or using the desktop viewer, I was starting to think that it might have something to do with my monitor being at 144 hertz.  But I've also had my system freeze just by launching the app.

Level 3
Also to note - my issues aren't stemmed from the beta build. When I reinstall, my beta opt-in is off so this seems to be on any (maybe recent?) version.

Juin_Roet mentioned he has a 144 htz monitor, I have recently installed one since last running the software. Unfortunately, unplugging that didn't resolve any other issues.

Only other thing I changed was moving from an i7 to a Ryzen 5. I had to reinstall Windows at this time, obviously, so I don't really have any old logs/experiences to share on that.

Another strange thing to note - after the system hangs itself for about 20 seconds, my mouse goes bonkers. Invisible on 2nd and 3rd monitors, not changing back to a pointer, just stays as what it last was. I doubt it means anything, but figured I'd report as much as I could in hopes of finding an answer, as I'm at the bottom of the barrel.

Level 3
Possible update with a bit more info. Located in C:\Users\USER\AppData\Local\Oculus, I found PerfLogs, which I'm attaching the one that was made when I loaded the program.

First thing I noticed was "  "display_diags_direct_display_details": "No compatible GPU found for Direct Display"," which may be something? It moves down the list to

    "VideoCardList": [
            "Name": "NVIDIA GeForce GTX 980"

So who knows if that error means anything. But the next piece got me too.

    "CpuList": [
            "Name": "AMD Ryzen 7 1700 Eight-Core Processor

That is not the CPU I have. I've got the Ryzen 5. I went and made sure it wasn't overclocked, and it's stock ATM. If there is another log I should be locating, please let me know so I can review.

Level 3
Is there a more official support location I should go to for this?  The thing is unusable until I can fix this issue from a fresh OS install...

Level 5
FWIW, I'm on a Ryzen 1700 also, and a GTX 1070.
Apart from the Rift, the card has a 1080p monitor and a 4K HDR TV connected.

Level 5
It just occured to me to check the event log after one of these crashes, and in System events, I found the following:

First, a Service Control Manager error that says (exact text may vary, as my Windows is in Spanish)

The OctBroker service shut down with the following error:

Incompatible request.

Then there's a couple of information events, and then come two identical DistributedCOM errors that say (again, I'm translating this myself so it may not be the exact text in English):

The application-specific permission configuration doesn't grant the Local Activation permission for the COM server application with CLSID

and APPID 
to the user NT AUTHORITY\LOCAL SERVICE with SID (S-1-5-19) at the address LocalHost (with LRPC) running in the application container with SID Not available (Not available). This security permission may be modified via the Component Services administrative application.

I checked Google and the OctBroker service is called "Microsoft Octagon Broker Service".
No clue what this is. Had never heard of any Microsoft Octagon until this day.

Anyone makes any sense out of this?

Level 5
@cybereality any chance you can have someone look into this? My PC is otherwise perfectly stable (no overclock), and I've already reinstalled the OS and the issue still occurs.
Also, there's other people having the same issue.

I'm guessing the PC dies the moment Oculus Home initializes the Rift as a display.
The "new hardware" sound plays, my monitor loses signal, and shortly after (the time varies) the PC reboots.

Level 16
Can you please upload you LogGatherer zip file? See here for how to find it.
You can also submit a support ticket for help. Thanks.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV