cancel
Showing results for 
Search instead for 
Did you mean: 

PCVR stop start hitching

Help!

 

I can no longer play PCVR (Quest 2 AND Rift S). Problem has started in the last few weeks.

 

Symptoms;

 

Any game launched from steam - but not a steam VR title for example; Euro Truck Simulator 2.

Select titles launched from steam that are steam VR compatible for example; Assetto Corsa.

 

Titles that run via steam VR without issue; Skyrim VR, Boneworks, Carrier Command VR.

 

Launch a game and it starts but keeps freezing every 5-10 seconds for a period of 2-10 seconds with the sound hitching, warping and skipping. In between freezes the game will run perfectly, debug tool shows plenty of overhead etc. During freezes the head tracking still works but nothing outside of the frame when it freezes is rendered. Strangely the game runs perfectly if I open the task manager and have it in focus, this of course prevents any interaction with the game itself.

 

I have ruled out the Link cable as this also happens with Air Link and some titles, as described above run flawlessly.

 

I have tried the following;

Fresh install of oculus app on PC.

Ensure all settings are default in the Debug tool.

Tried using my  Rift S.

Set priority to high on OVR services via Task Manager.

Verified files of the games on steam including SteamVR.

Set the lowest possible graphic settings in game.

Opted out of Beta on the Oculus APP on PC.

Terminated all programs such as razer synapse, switched off bullguard AV.

Using headset instead of oculus audio.

Updating to the latest Nvidia driver.

 

System Specs;

Intel i7-9700k

RTX 3080 Amp Holo

32GB DDR4 3200mhz RAM

GB Z390 Motherboard

 

2 REPLIES 2

*update*

 

Further to the above;

 

Tried playing Derail Valley which displayed the same stop starting issue. Rather than Task manager being open making it run better, simply having any window other than the game in focus allows the game to run as expected (this is the case with any game that is stop-start hitching). This works fine with Derail Valley as you can still play it when the client as alt-tabbed.

 

Additional things I have tried;

Changing the launch extension in ETS2 from -oculus to -openvr

Changing the default openxr runtime to SteamVR

Staring at my monitor pondering what on earth the problem is

 

I really don't have the stomach for a reinstall of windows. As this happens regardless of whether I try my Rift S or Quest 2 and that games like Boneworks and SkyrimVR are uneffected I'm at a loss.

 

Hey there nicholas.hickman.902, thanks for reaching out about this! We'll get your PCVR working again so you can enjoy all your favorite games. Below I've outlined some troubleshooting steps you could try to alleviate any potential link issues.

Are there any updates to Windows/GPU/USB?

Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but is applicable to Quest/Quest 2 as well.

For Windows, there's an article on how to check for updates here!

If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.


Conflicting software.

There are a few pieces of software known to cause issues with Oculus processes; ASUS AI Suite or ASUS Ai Suite 3. This software is an all-in-one application that allows users to make modifications to motherboard components such as CPU, USB, Wi-Fi, LAN and more. When troubleshooting any issues that use devices affected by this software, it’s recommended to uninstall ASUS AI Suite, if installed, and test to see if the issue remains or disappears. Your PC may need to be restarted after removing this software.

If present, also uninstall Oculus Tray Tools, as it contains settings for resolution, super sampling, etc. that can impact performance.


Other Options.

Below are a few other options you could try if none of the above options work.

Try alternate USB 3.0 ports, after removing any non-Oculus USB devices, to help account for USB bandwidth and issues with specific ports. Stripping the connections to a minimum may be helpful; connect only the headset, as well as your mouse and keyboard.

Attempt to enroll in, or opt out of, the Public Test Channel using steps from the article here.

Repair the oculus PC Application using these steps. Once complete, restart the PC and attempt to enable Link again.


Submit a Support Ticket.

Collect Oculus Diagnostic Logs and submit them in a support ticket here so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.


If you have any other questions or concerns, we'd be happy to help! Cheers!