cancel
Showing results for 
Search instead for 
Did you mean: 

Pesky active runtime bug work around

dan.rossi.90
Level 4

I'm unable to change the active runtime it does nothing. Not even run as admin. Manual registry change immediately got my headset connected again. It broke when I tried to test mixed reality simulator

"Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Khronos\OpenXR\1"  Active Runtime value to "C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json"

3 REPLIES 3

Nawarius
Level 3

Up to this value "C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json"

There was this "C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_32.json"

 

I changed it, but still WebXR doesn't work. Chrome gives me this error:

Could not create a session because: Something went wrong initializing the session in the runtime
XRSession creation failed: The specified session configuration is not supported.

On this samples https://immersive-web.github.io/webxr-samples/

Any other ideas how to solve this problem?

dan.rossi.90
Level 4

Try Chrome Canary. I had to test on that for a while under Windows 11. I have to set my software to the beta channel also and let it reinstall. 

I solved the problem by reinstalling Windows. I had Windows 10 LTSC. I installed windows 10 pro clean and everything was decided by itself