cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Beat Saber over link cable and steam vr

maks.pys.9
Level 2

Hi, I've started having a problem with beatsaber. It seems to Me that game is lagging when bigger object like wall or something spawns but steam vr shows good fram and oculus debug tool shows 120fps, also fps counter stays at 120fps. I am using oculus quest 2 with resolution set to 1.3x and bitrate of 480Mbps. Is somebody having same problem?

My pc:

- i7 10700kf

- rtx 2060

- 16gb ram 3000MHz

- SSD drive for storage

8 REPLIES 8

TomCgcmfc
Level 15

You probably need to drop your bitrate down to about 300mbps and also your refresh rate to at least 90Hz, maybe even 72/80Hz.  Even my Q2/rtx3090 struggles with 120Hz, lol!  Also make sure to set your SteamVR visuals manually to 100% and disable advanced super sample filtering.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

maks.pys.9
Level 2

I tried changin it but no luck. I tried changin resolution down, changing refreshrate, bitrate and Nothing. And The wierdest thing is that this kind of lag only happends in beat saber, other games like oneward, phasmophobia are running smotly. Sometimes even vrchat wiil ran ad 120hz. So i thing this is some bigger problem. 

Sorry but you probably need a better gpu imho.  Also, try a lower refresh rate like 80Hz.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Still Nothing, even when my per eye resolution set to 812px. But when other games lag i see something it in performance meter but there the  everything shows that its normalna and frame rate is allways staing the same. I can give you a screenschot with fps over time. 

PITTCANNA
Level 13

@maks.pys.9 wrote:

Hi, I've started having a problem with beatsaber. It seems to Me that game is lagging when bigger object like wall or something spawns but steam vr shows good fram and oculus debug tool shows 120fps, also fps counter stays at 120fps. I am using oculus quest 2 with resolution set to 1.3x and bitrate of 480Mbps. Is somebody having same problem?

My pc:

- i7 10700kf

- rtx 2060

- 16gb ram 3000MHz

- SSD drive for storage


The rtx 2060 is not a good card to attempt 120hz, at quest 2 resolution even if you leave it a 1.0.

 

I have a 2080 super I7 16gb, on one of my setups and max i will ever go is 80 to 90 hz, keeping the resolution 1.0 to 1.2.  The more you try to tax system up to 120 the more lag you induce into it.

 

Your setup is all wrong

480mbps is kinda silly over link wired (max recommended is 300mbps and even beyond 250 you not going to notice anything)

1.3x render (i run 1.3x on my 3080 ti setup the 2060 is more of a 1.1x max) but for beat saber i would even run .9

120hz (That card at 1440p runs comfortably at 75 to 80 hz)

https://www.techspot.com/review/1781-geforce-rtx-2060-mega-benchmark/

 

 

I found a way to fix it wihout changing refreshrate. I just experimented with advance 3D settings in Nvidia Control Panel and now it is wornikng fine, with Refrashrate set to 120Hz and resolution up to 3648x1856 px what translates in to 1.3x.

@maks.pys.9  I have found in the past that if your monitor supports higher refresh rates (mine does up to 144Hz) then changing my win10 display properties to 120Hz does seem to improve my Q2 120Hz refresh rate a little bit (= tiny bit smoother).  This is not necessary, or advisable, to do this with nvidia control panel imho.  In any case, 120Hz still sucks with my Q2/rtx3090.  Also, I find that going above 100Hz on my monitor is not very useful so I leave it set to that.

 

I still find it hard to believe that you're getting good results at 120Hz with a 2060 gpu.  I guess as long as you're happy that's great.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

It seems for me it is problem with the driver. I change unnesery thing from auto to off. And it was all.