Showing results for 
Search instead for 
Did you mean: 

Purchase Not installing but money taken

Level 3

Just purchased Sniper Elite from the headset app store, after pin code entry nothing happen. When I go to the game in the store the purchase button is a loading wheel. I have received a receipt but have no game. 

On the Phone app the game is purchased.


Level 2

Exactly the same issue here. Purchased 40mins ago and just have the spinning icon on the app store page for it.

Level 2

Same here. Phone app says waiting for headset to be connected to the internet. Which it clearly is since I bought from within the headset! I tried the reboot method motioned in other boards which did not help. 

Level 2

Exact same issue here, just got the Quest 2 last night for my birthday and this is my first experience with the device so that’s sad. Looking on this forum, there’s people that say they are having these issues since the latest update, so I’m hoping it’s something that oculus can fix within the software and hoping it’s not that my device it defective 

Level 2

I'm having the same issue, app says Install Queued > Headset not connected but in devices it clearly is.

Level 2

Same here, just purchased Sniper Elite Vr and can't find it in the library. And infiny loading for the play button in the store

Level 3

Having the same problem too. Before I realized I also got Vader Immortal Ep 1 and that's not downloading either

Level 2

Same, has anyone hear heard a fix from oculus yet?


Level 3

Same here, even tried to factory reset and same issue, spinning wheel to install the game. Now all games I try to install have the same problem 😞