cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Air Link and Cable Link refusing to work properly

doooombo
Level 3

Recently I was having issues with cable link whenever I tried to launch Steam VR or any applications that use it (disclaimer: Steam is the only platform I use to play VR games at the moment). Whenever I even try to launch Steam VR with cable link, the link crashes as if it was disconnected manually and then prompts me to activate link again after kicking me back to the regular quest 2 menu.

I've only had my quest 2 and the cable for nearly 2 months now, and seeing as how this might be a software issue I decided to try out Air Link instead.

On my first attempt, albeit it seemed to work at first, trying to launch Steam VR or any other VR games via Air Link seemed to glitch in a way that, although Steam VR recognized my hardware, it didn't update the visuals correctly so I was still stuck with the regular Link menu.

I've been having the cable link issue for the past 2 weeks and this air link issue is relatively recent as I've only tried it once today.

I am 100% certain this isn't an issue corresponding with my PC as prior to these issues I was perfectly able to run games like Half-Life: Alyx, Gorn, and VR Chat. If anyone else can relate to these issues please let me know and let me know if there are ways to fix this, unless I simply have to wait for another software update.

1 REPLY 1

doooombo
Level 3

I forgot to mention; whenever the cable link stops working and I try to enable it again, I'm stuck with a black screen and am forced to restart Steam VR, which ensues with the same issue once again and vice versa.