cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2: QuestLink + 120 fps = white vertical line on far right side of right eye.

K1NG.PROPHET
Level 3

Hello everyone,

 

When I use Quest Link (wired and wireless) with 120hz enabled, I get a vertical line of flickering white squares on the far right side of the right eye.  It's not an overheating issue as it will happen from the moment I connect to my PC with 120hz enabled.  It only appears in the device and does not show up on the preview image on my PC.  Is this a common issue?  I searched the forums for vertical white line 120hz and wasn't finding anything.

example of what I see on the right edge of the right screen.  it's visible and distracting.example of what I see on the right edge of the right screen. it's visible and distracting.

This is an example of what I see.  Happens with wireless and wired (using usb 3.0 c to c cable) It's always in the right eye near the edge.  It's visible and distracting.  Happens at every supersampling multiplier as well.

 

Anyone else experience this or know of a possible fix?

 

My system is stable and temps are cool.   My relevant system specs are Win11 with latest updates, 3080 Ti, 10900k, 16GB DDR4 4400, and only m.2 storage.

20 REPLIES 20

OculusSupport
Community Manager
Community Manager

Well hey there thanks for sharing this with us, we want to help and get you back into the game!

 

We noticed you might be having some Link issues, with this weird white line do you know if it's visible across the entire UI? And do you know if it appears while not tethered to the PC?

 

If this occurs through your experience we can try and remedy this by trying a few things out:

 

- What kind of Link cable are you using? For best performance, we recommend using the official Link cable by Meta.

- Try to have as little USB plugged in while using Oculus Link.

- Ensure your Link connection is correct:

  1. Open the Oculus app on your PC.
  2. Turn on your Quest 2 or Quest.
  3. Plug your USB 3 cable into a USB 3.0 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  5. When prompted to Enable Oculus Link, select Enable to begin remote rendering using Oculus Link.

Get back to us with an update on your issue and if needed we can provide further help.

TomCgcmfc
Level 15

I think 120hz is a big ask with PCVR.  Even struggles with my 3090.  I find dropping the bitrate down a bit (say from 500 to 300) as well as the res slider helps a bit.  Also, going into ODT and changing the FOV default 0,0 to 0.8, 0.8 helps a bit.  Maybe I’m not very refresh rate sensitive because I’ve found 80Hz works best for me.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

ducko_
Level 3

I believe I have the same issue, started happening after v42. It seems to be most visible when veiwing in dark areas. Through my testing I found I can reduce the frequency of the artifacts by either disabling link sharpening or switching to 90hz (or lower). With 120hz+sharpening it is constantly occuring in the sides of both displays.

 

I've contacted support and tried everything under the sun to fix it. I'm almost certain it's just another example of the software update teams incompetence. I think it's probably on the headset side since sharpening affects it and the artifacts don't appear when screen mirroring in the debug tool.

 

It is weird how I can't find many posts about it but I think it's plausible that there aren't that many people who play with 120hz capable VR PC, use low ipd to see the corner of the display it affects clearly and also pay close enough attention in a dark area to notice it. It could be related to a hardware issue on the latest update since I also have a 3080 ti.

 

Here's a video of my issue please let me know if what I've described matches yours.

https://youtu.be/lOF0quzrDWE

YES! That is exactly what I see! Glad I am not the only one. It sure is distracting isn't it...

is that the diagnostic tool? i will try anything at this point.

@ducko_  I only see those occasional white snow artifacts if I have ODT mobile asw enabled or auto.  Try disabling it.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

I can confirm this does not make the snow artifacts go away, at least on my end.  Maybe I did something wrong... I opened ODT, relaunched as admin, set Mobile AWS to disabled, restart oculus service, then relaunched questlink via the headset.  

Pretty sure there is nothing we can do as users to fix it. I have tired everything from factory resetting the headset to a fresh windows 10 install it still happens. As I said, its most likely a software bug on the headset side (possibly related to the ghosting/latency correction?) we have no control over it and they don't allow us to downgrade updates. 


We will be lucky if this gets fixed within the next 5 updates. In the meantime, you can go ahead and contact support they will ask you to update third-party drivers then offer you RMA replacement because they have no access to view the full patch notes or troubleshoot their own software. Then after receiving your replacement and finding the issue is still present on the new headset you can scroll through these forums and look at the pages of issues and complaints that go unresolved for several updates and be amazed at how a billion dollar company could be so incompetent...

 

In all seriousness the only workaround till we get an official update is to disable sharpening (in ODT) and use 90hz which sucks but at least the artifacts only show up every couple secs instead of constantly flickering.

@TomCgcmfc Yes ever since it released mobile ASW causes a similar issue that was the first thing I thought of when I got this issue however mASW enabled causes it to appear across the entire display. This happens even with mASW disabled but artifacts are far more frequent and isolated to the corners of the display. Switch to 120hz in the app, set link sharpening to enabled and open the steam vr void and you will see what we mean.

@K1NG.PROPHET You need to disable "Link Sharpening" it wont make them completely disappear and not having sharpening sucks but it reduces it significantly.