Showing results for 
Search instead for 
Did you mean: 

Quest 2 does not connect to PC via Link Cable from the Quick Settings

Level 2

Hi, My Quest 2 stopped connecting to my PC today. It usually connects okay, but now, when I try to connect via Quick Settings > Oculus Link in the headset, the screen in the headset goes black for a second and then reverts back to the main menu in the headset.


I have the latest software version and the PC app the devices section displays the headset as 'green' and connect, all okay. I have tried powering off and on, restarting my PC, repairing the PC app, and removing and re-adding the headset via the wizard in the PC app. None of this works 😞


Can you help? 


Oculus Community Manager
Oculus Community Manager

Oh no! We would to help you resolve this matter.


Thank you for providing us with the troubleshooting steps you have tried prior to reaching out. So to weigh out this matter, could you please provide the following details:

  • Is your USB cable connected to a USB 3.0 port?
  • How many other USB devices do you currently have connected to your PC? (Try testing with the bare minimum of USB devices connected to PC, such as just the keyboard and mouse).
  • What type of cable are you using? (if you are using a third party cable, please include the link and any possible photos.)
  • Have you only attempted to enable your link using the quick settings?

Please be sure to respond back here, so that we can continue to resolve this matter together.

Level 10

This might sound stupid, but you might want to check that Air Link is disabled in your headset. If that's not the issue, try checking to see if there's an update for your Quest. I think they released a version update recently, so the issue might be that your headset is on a different version then the desktop app.

Lo, a quest! I seek the threads of my future in the seeds of the past.

Thanks, I made sure the air link is disabled but no luck. I also tried connecting via air link instead of the cable. I can pair okay withy my PC but get the same problem. I've resorted to trying a new install of the Oculus PC app, and have done a factory reset on the headset, will give that a go once the apps' installed. Thanks again.

Level 10

I brought up the possibility of needing an update since that can be an issue. Version updates are not released to everyone at the same time, but in waves. Good news is that this lets Oculus find and (hopefully) iron out problems before they become widespread. However this does mean that when an update is sent out, it's quite possible for your desktop app and headset to end up being on different versions. Which breaks both Oculus Link and Air Link. And that's bloody annoying. Also, you might want to keep from enabling Public Test Channel in your desktop app. That'll cause your desktop app to update at times to a newer version that the Quest doesn't have access to. Which again will break Oculus Link and Air Link.

Lo, a quest! I seek the threads of my future in the seeds of the past.