cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 microphone not working at all

ShadowHive
Level 2
So, ive tried almost everything now but the mic of my quest 2 just isnt working. I looked trough all the settings, made sure that its turned on but there´s no voice when I record a video or play a game. Same goes for playing trough oculus link. Made sure to select the right microphone in sound settings but still not working. What am I doing wrong?
16 REPLIES 16

Fangzhou
Level 6
This problem was never fixed since Oculus Link beta. The Oculus Virtual Audio Device microphone must be in used when connecting to Oculus Link, otherwise the microphone won't work. 
A simple way to temporary fix this is that:  go into the device properties -> other device properties of Oculus Virtual Audio Device microphone, in the second tab select "listen to this device", and let any output device listen to the Oculus Virtual Audio Device. After connecting Oculus Link, disable the "listen to this device". You will have to do this every time. 
Since Oculus can't fix this after 1.5 years, I don't think Oculus have the ability to fix this bug. 

I've had the issue of mic not working since day one. I am using the headset solo without a PC connection. It must be a software issue. Mic is not muted, I'm updated to V 28 and I've done a factory reset. It worked for 1 day after reset and only in YouTube voice to text. Doesn't work in any games nor does it work with the new voice command options. I don't think the mic is broke but there is something wrong with the software that controls it....no fix found as of yet

Norlia_Tiemeth
Level 2

Still no fix

Are you making a statement or asking a question? 

I've stopped using the quest 2 because of the microphone issue. Many games require you to communicate with other players and they are unenjoyable without mic capability.

 

Maybe I will try again after another software update or maybe one more factory reset.

What do you think? It's Oculus, obviously they won't fix it. Link and Air Link have the same issues and I've tried all the "supposed" fixes.

MeticulousSeven
Level 2

Having the same issue, glad I'm not alone! Using the Q2 solo, no PC involved, microphone stopped working in all games. Have factory reset and all that jazz, no dice.

 

I hate to say it, but I'm convinced at this point that we have had a hardware failure, and no patch is ever gonna bring our microphone back. Oculus did approve an RMA for my unit, but wanted all original packaging and I don't think I have everything so I never shipped it.

 

Best of luck, please update us on this thread if you ever find a fix!

Ignominy
Level 2

If you have a quest wrap, check half an inch to the left of the volume slider. If there's no hole there, your wrap is probably covering the mic, indirectly making the mic unusable while the wrap is there. Peel off the wrap, and punch a hole with like a toothpick or something along the lines of that where the mic hole is, and put it back on.